aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-apcu
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-07-28 17:30:19 +0300
committerJakub Jirutka <jakub@jirutka.cz>2018-07-28 19:53:10 +0200
commitf9709870e5deb3bf57ca3ae6e31da864905f0a3c (patch)
tree0d817dc0b00110d9adabb98dafbc27099edf14c4 /community/php7-apcu
parentc9087253cc7246bcc42b7b6895ec97d957f7217b (diff)
downloadaports-f9709870e5deb3bf57ca3ae6e31da864905f0a3c.tar.bz2
aports-f9709870e5deb3bf57ca3ae6e31da864905f0a3c.tar.xz
community/php7-apcu: add missing file, use https url and source
Diffstat (limited to 'community/php7-apcu')
-rw-r--r--community/php7-apcu/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/php7-apcu/APKBUILD b/community/php7-apcu/APKBUILD
index f0a0fb9254..4aa24569e4 100644
--- a/community/php7-apcu/APKBUILD
+++ b/community/php7-apcu/APKBUILD
@@ -4,14 +4,14 @@ pkgname=php7-apcu
_pkgreal=apcu
# release 5 is php7+
pkgver=5.1.12
-pkgrel=0
+pkgrel=1
pkgdesc="PHP extension APC User Cache"
-url="http://pecl.php.net/package/$_pkgreal"
+url="https://pecl.php.net/package/apcu"
arch="all"
license="PHP"
depends=""
makedepends="pcre-dev php7-dev autoconf"
-source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -31,6 +31,8 @@ package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir"/ install
+ install -D -m644 apc.php "$pkgdir"/usr/share/php7/apcu/apc.php
+
install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}