aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-mcrypt
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-27 15:27:52 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-31 01:51:44 +0300
commit5f871566ea0b505c40bb1eb491b3a9ede4e3ba0c (patch)
tree3773adf188bcc6afcb6fcdd68e23d95f46dd3750 /community/php7-mcrypt
parentac7e5e0a83fe9c831741e657a7be44139072d630 (diff)
downloadaports-5f871566ea0b505c40bb1eb491b3a9ede4e3ba0c.tar.bz2
aports-5f871566ea0b505c40bb1eb491b3a9ede4e3ba0c.tar.xz
community/php7-mcrypt: new aport
Replacement for the mcrypt subpackage that was part of PHP7, but has been removed as of PHP 7.2.
Diffstat (limited to 'community/php7-mcrypt')
-rw-r--r--community/php7-mcrypt/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/php7-mcrypt/APKBUILD b/community/php7-mcrypt/APKBUILD
new file mode 100644
index 0000000000..36dc5ec481
--- /dev/null
+++ b/community/php7-mcrypt/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=php7-mcrypt
+_pkgreal=mcrypt
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Provides bindings for the unmaintained libmcrypt."
+url="https://pecl.php.net/package/mcrypt"
+arch="all"
+license="PHP"
+depends=""
+makedepends="pcre-dev php7-dev autoconf libmcrypt-dev"
+source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ # One test fails with PHP 7.2.3
+ rm tests/bug8040.phpt
+
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="1677202715499a41ac6999089257a059106e58cbac06ca8a7dd2e9edd28be5a4118234dd7468110e9e3d7f9de5d099367848fe84bcd06716ea56645c9015c578 mcrypt-1.0.1.tgz"