aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-oauth
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-21 04:50:41 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-03-29 23:54:43 +0300
commitf491cba31971ca3524b3d1c37799874dc47102af (patch)
tree564c1b0920e08922f365de99e8668e4bc888e136 /community/php7-oauth
parent81969492168f2b24f810a9b964f781ef88db5763 (diff)
downloadaports-f491cba31971ca3524b3d1c37799874dc47102af.tar.bz2
aports-f491cba31971ca3524b3d1c37799874dc47102af.tar.xz
community/php7-oauth: modernize
Diffstat (limited to 'community/php7-oauth')
-rw-r--r--community/php7-oauth/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/php7-oauth/APKBUILD b/community/php7-oauth/APKBUILD
index f780fd8e5b..3cd79a59a8 100644
--- a/community/php7-oauth/APKBUILD
+++ b/community/php7-oauth/APKBUILD
@@ -3,30 +3,32 @@
pkgname=php7-oauth
_pkgreal=oauth
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="OAuth is an authorization protocol built on top of HTTP."
url="http://pecl.php.net/package/$_pkgreal"
arch="all"
license="PHP"
depends=
-makedepends="php7-dev autoconf pcre-dev"
-install=""
-subpackages=""
+makedepends="php7-dev autoconf pcre-dev curl-dev"
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
-
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
cd "$builddir"
- phpize7 || return 1
- ./configure --prefix=/usr --with-php-config=php-config7 || return 1
- make || return 1
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir"/ install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
}