aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/APKBUILD
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-11 21:00:14 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-20 13:37:12 +0000
commit286982fe487f3a33c9a8195b19848a9c4f28e609 (patch)
tree744783850abeadd20909fb54cf3ade5d3f0020eb /community/php7/APKBUILD
parent4fb44b65103a852adad86f575f0ac998be71dea4 (diff)
downloadaports-286982fe487f3a33c9a8195b19848a9c4f28e609.tar.bz2
aports-286982fe487f3a33c9a8195b19848a9c4f28e609.tar.xz
community/php7: disable jit on s390x
Diffstat (limited to 'community/php7/APKBUILD')
-rw-r--r--community/php7/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index f76b0dbc3b..ae4f0c25b0 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7
_pkgreal=php
pkgver=7.0.17
-pkgrel=5
+pkgrel=6
pkgdesc="The PHP language runtime engine - 7th branch"
url="http://www.php.net/"
arch="all"
@@ -71,6 +71,7 @@ prepare() {
}
_build() {
+ [ "$CARCH" = "s390x" ] && _disable_pcre_jit="--without-pcre-jit"
export EXTENSION_DIR=/usr/lib/$pkgname/modules
./configure \
--build=$CBUILD \
@@ -89,6 +90,7 @@ _build() {
--disable-short-tags \
--with-openssl=shared --with-kerberos --with-system-ciphers \
--with-pcre-regex --with-pcre-dir \
+ $_disable_pcre_jit \
--with-zlib=shared --with-zlib-dir \
--enable-bcmath=shared \
--with-bz2=shared \