aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2018-03-30 22:41:16 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-31 01:51:44 +0300
commitac7e5e0a83fe9c831741e657a7be44139072d630 (patch)
tree9d7ad3aac86857c21ddfc95e4b006b7575361095 /community/php7
parent1489b024a895cfafd987b92e74e42d9cea137ef9 (diff)
downloadaports-ac7e5e0a83fe9c831741e657a7be44139072d630.tar.bz2
aports-ac7e5e0a83fe9c831741e657a7be44139072d630.tar.xz
community/php7: upgrade to 7.2.4
Diffstat (limited to 'community/php7')
-rw-r--r--community/php7/APKBUILD20
-rw-r--r--community/php7/fix-tests-devserver.patch4
-rw-r--r--community/php7/php7-fpm-version-suffix.patch36
3 files changed, 42 insertions, 18 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 845912f223..728e331f02 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -25,9 +25,9 @@
pkgname=php7
_pkgreal=php
-pkgver=7.1.15
+pkgver=7.2.4
pkgrel=0
-_apiver=20160303
+_apiver=20170718
_suffix=${pkgname#php}
# Is this package the default (latest) PHP version?
_default_php="yes"
@@ -64,9 +64,9 @@ makedepends="
libedit-dev
libical-dev
libjpeg-turbo-dev
- libmcrypt-dev
libpng-dev
libressl-dev
+ libsodium-dev
libwebp-dev
libxml2-dev
libxpm-dev
@@ -126,7 +126,6 @@ _extensions="
json
ldap
mbstring
- mcrypt
mysqli
mysqlnd
odbc
@@ -149,6 +148,7 @@ _extensions="
simplexml
snmp
soap
+ sodium
sockets
sqlite3
sysvmsg
@@ -287,9 +287,8 @@ _build() {
--with-ldap-sasl \
--with-libedit \
--enable-libxml \
- --with-libxml-dir=/usr \
+ --with-libxml-dir=/usr \
--enable-mbstring=shared \
- --with-mcrypt=shared \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=/run/mysqld/mysqld.sock \
--enable-mysqlnd=shared \
@@ -316,6 +315,7 @@ _build() {
--enable-simplexml=shared \
--with-snmp=shared \
--enable-soap=shared \
+ --with-sodium=shared \
--enable-sockets=shared \
--with-sqlite3=shared,/usr \
--enable-sysvmsg=shared \
@@ -333,7 +333,7 @@ _build() {
--enable-zip=shared \
--with-libzip=/usr \
--with-zlib \
- --with-zlib-dir=/usr \
+ --with-zlib-dir=/usr \
$@
make
}
@@ -638,13 +638,13 @@ _mv() {
mv $@
}
-sha512sums="db10c0138a74165c6373f0d6cc7f5ca1f6b1ae26359cc2e2a9dec8895a491b8adccee59601cb9325e54768e9cca643e9f73858fef5cbe6502c683131f9cc8ccf php-7.1.15.tar.bz2
+sha512sums="036348c7dd1b14cb8d843682a800c396a2a712db3113fb1443826171d4fc75e326b1e239807cd59cbc3c703ffdba3e2a48033052c01552dd1c9454c6abf20fe0 php-7.2.4.tar.bz2
1c708de82d1086f272f484faf6cf6d087af7c31750cc2550b0b94ed723961b363f28a947b015b2dfc0765caea185a75f5d2c2f2b099c948b65c290924f606e4f php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
274bd7b0b2b7002fa84c779640af37b59258bb37b05cb7dd5c89452977d71807f628d91b523b5039608376d1f760f3425d165242ca75ee5129b2730e71c4e198 php7-module.conf
6593accfe1ef0d9d28d257b2825823afdbfaa72bbf2e09e4ed689b644571a0d085cd4d6c92ffdff6ca9d0bb6d31cf84e5db5c4a4d88f192bba3f95a0c9b1dfd7 disabled-tests.list
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
-a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch
+6d4aa75b94ce7c88f97574a06964fafd7cb6657c1cb19c0b93776dedef05857331cce9c40f69a442ef84c66aa9137ad9f6197cc25f2384a27b8fd7350838292e php7-fpm-version-suffix.patch
f8ecae241a90cbc3e98aa4deb3d5d35ef555f51380e29f4e182a8060dffeb84be74f030a14c6b452668471030d78964f52795ca74275db05543ccad20ef1f2cc allow-build-recode-and-imap-together.patch
-01c3c65f153ea92192f2b2694d93a086ffa67c282fe046f877842942692c25666e4154a09aba6c2161f7f2a3b6595f4d79573e9ee74aec774a95f2f9725846f9 fix-tests-devserver.patch"
+f8bb322e56df79dd9f391737fb8737945cc730b14c7dc2ae8688979c565a9b97f5f2a12c9fcd0d8124624a9d09bd10228147d9e999bb94909bbe249f0a50646c fix-tests-devserver.patch"
diff --git a/community/php7/fix-tests-devserver.patch b/community/php7/fix-tests-devserver.patch
index 3f8220c5a1..80a72f0f17 100644
--- a/community/php7/fix-tests-devserver.patch
+++ b/community/php7/fix-tests-devserver.patch
@@ -11,7 +11,7 @@ happens here...
--- a/run-tests.php
+++ b/run-tests.php
-@@ -1918,6 +1918,9 @@
+@@ -2005,6 +2005,9 @@
// Does the output match what is expected?
$output = preg_replace("/\r\n/", "\n", trim($out));
@@ -19,5 +19,5 @@ happens here...
+ $output = preg_replace("/^PHP [0-9.]+ Development Server started at .*\n\n?/m", "", $output);
+
/* when using CGI, strip the headers from the output */
- $headers = "";
+ $headers = array();
diff --git a/community/php7/php7-fpm-version-suffix.patch b/community/php7/php7-fpm-version-suffix.patch
index e8aee952f3..0d4dee7c2e 100644
--- a/community/php7/php7-fpm-version-suffix.patch
+++ b/community/php7/php7-fpm-version-suffix.patch
@@ -1,20 +1,33 @@
--- a/sapi/fpm/fpm/fpm_conf.c
+++ b/sapi/fpm/fpm/fpm_conf.c
-@@ -1180,3 +1180,3 @@
+@@ -1205,7 +1205,7 @@
+ }
+
if (!fpm_global_config.error_log) {
- fpm_global_config.error_log = strdup("log/php-fpm.log");
+ fpm_global_config.error_log = strdup("log/php7/error.log");
}
-@@ -1191,3 +1191,3 @@
+
+ #ifdef HAVE_SYSTEMD
+@@ -1216,7 +1216,7 @@
+
+ #ifdef HAVE_SYSLOG_H
if (!fpm_global_config.syslog_ident) {
- fpm_global_config.syslog_ident = strdup("php-fpm");
+ fpm_global_config.syslog_ident = strdup("php-fpm7");
}
-@@ -1683,3 +1683,3 @@
+
+ if (fpm_global_config.syslog_facility < 0) {
+@@ -1710,7 +1710,7 @@
+ if (fpm_globals.prefix == NULL) {
+ spprintf(&tmp, 0, "%s/php-fpm.conf", PHP_SYSCONFDIR);
} else {
- spprintf(&tmp, 0, "%s/etc/php-fpm.conf", fpm_globals.prefix);
+ spprintf(&tmp, 0, "%s/etc/php7/php-fpm.conf", fpm_globals.prefix);
}
+
+ if (!tmp) {
+
--- a/sapi/fpm/php-fpm.conf.in
+++ b/sapi/fpm/php-fpm.conf.in
@@ -16,3 +16,3 @@
@@ -38,18 +51,29 @@
--- a/sapi/fpm/www.conf.in
+++ b/sapi/fpm/www.conf.in
-@@ -252,3 +252,3 @@
+@@ -256,7 +256,7 @@
+
+ ; The access log file
; Default: not set
-;access.log = log/$pool.access.log
+;access.log = log/php7/$pool.access.log
-@@ -316,3 +316,3 @@
+ ; The access log format.
+ ; The following syntax is allowed
+@@ -320,7 +320,7 @@
+ ; The log file for slow requests
+ ; Default Value: not set
; Note: slowlog is mandatory if request_slowlog_timeout is set
-;slowlog = log/$pool.log.slow
+;slowlog = log/php7/$pool.slow.log
-@@ -410,3 +410,3 @@
+ ; The timeout for serving a single request after which a PHP backtrace will be
+ ; dumped to the 'slowlog' file. A value of '0s' means 'off'.
+@@ -418,6 +418,6 @@
+ ; specified at startup with the -d argument
+ ;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
;php_flag[display_errors] = off
-;php_admin_value[error_log] = /var/log/fpm-php.www.log
+;php_admin_value[error_log] = /var/log/php7/$pool.error.log
;php_admin_flag[log_errors] = on
+ ;php_admin_value[memory_limit] = 32M