aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-07 15:02:16 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-07 15:03:46 +0000
commit3c80ffcde355ba9c2b4629b4bdf3efef1278811a (patch)
treee294e4998e5dcbe0fb50d751ddf2325b13d6398f /community/psmisc/APKBUILD
parent865fdb4dd3ee82b4930af7707486229aa4ee8283 (diff)
downloadaports-3c80ffcde355ba9c2b4629b4bdf3efef1278811a.tar.bz2
aports-3c80ffcde355ba9c2b4629b4bdf3efef1278811a.tar.xz
community/psmisc: fix build for ppc64le
https://github.com/leitao/aports/commit/9f4395581c9d594d2ffed51f2354c991e2c88c1a
Diffstat (limited to 'community/psmisc/APKBUILD')
-rw-r--r--community/psmisc/APKBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/community/psmisc/APKBUILD b/community/psmisc/APKBUILD
index 3022d64b34..2bd302c7df 100644
--- a/community/psmisc/APKBUILD
+++ b/community/psmisc/APKBUILD
@@ -1,17 +1,25 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=psmisc
pkgver=22.21
-pkgrel=1
+pkgrel=2
pkgdesc="A set of some small useful utilities that use the proc filesystem"
url="http://psmisc.sourceforge.net/"
-arch="all !ppc64le" #does not build yet for ppc64le
+arch="all"
license="BSD GPL"
depends=""
-makedepends="ncurses-dev"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.gz"
+makedepends="gettext-dev libintl ncurses-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.gz
+ include_limits.patch
+ peekfd_lintl.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ default_prepare
+}
+
build() {
cd "$builddir"
./configure --prefix=/usr \
@@ -27,6 +35,11 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="935c0fd6eb208288262b385fa656f1bf psmisc-22.21.tar.gz"
-sha256sums="97323cad619210845b696d7d722c383852b2acb5c49b5b0852c4f29c77a8145a psmisc-22.21.tar.gz"
-sha512sums="766aeb45687090b88b17176c5117a603e83fe92a13c013aea72c8ee80048adf02e18c7daa52ddfb8b2135f7c9a1bcae38896cdfb8d0158728d85a446c5e0d5ae psmisc-22.21.tar.gz"
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="766aeb45687090b88b17176c5117a603e83fe92a13c013aea72c8ee80048adf02e18c7daa52ddfb8b2135f7c9a1bcae38896cdfb8d0158728d85a446c5e0d5ae psmisc-22.21.tar.gz
+63dea6a65c4cabcfa06d225950bc78fd6ac42f7445b8d10bde5e86dd8d96eb89823e486d7635b78562da058642f87289356c416225563a8e1ccfc2e32d81e884 include_limits.patch
+ec84b84a02e48aed9f47a9efdd7ee4a4d409373751e9872e32c06912b506d9102a0526f244dcaff172598cd77e61344d38449a60181c2bbb010a674662e8f439 peekfd_lintl.patch"