aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-09-03 13:16:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-03 13:16:24 +0200
commit13f137009301601aa754889040f6619ae8187c5c (patch)
treecc6a425e789d3122b56e4fea5fb9c6849437b422 /community/psmisc
parentec100a5ad9287e67b98346103ccf6a614e13ed13 (diff)
downloadaports-13f137009301601aa754889040f6619ae8187c5c.tar.bz2
aports-13f137009301601aa754889040f6619ae8187c5c.tar.xz
community/psmisc: improve abuild, replace _builddir with builddir
Diffstat (limited to 'community/psmisc')
-rw-r--r--community/psmisc/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/psmisc/APKBUILD b/community/psmisc/APKBUILD
index 986d7d2b55..9671e8a734 100644
--- a/community/psmisc/APKBUILD
+++ b/community/psmisc/APKBUILD
@@ -8,18 +8,12 @@ arch="all"
license="BSD GPL"
depends=""
makedepends="ncurses-dev"
-install=""
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/psmisc/psmisc-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
+source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -29,7 +23,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}