aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-06-13 14:48:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-14 10:44:57 +0000
commita7183bc057fe6bdebb82319756308df4f4250310 (patch)
tree2ef6b05d85a32d590aec51844a2577465533eeaa /community/psmisc
parent1bee4d7678a0ca95150905281d1f255658d88366 (diff)
downloadaports-a7183bc057fe6bdebb82319756308df4f4250310.tar.bz2
aports-a7183bc057fe6bdebb82319756308df4f4250310.tar.xz
community/psmisc: bump to 23.0
Diffstat (limited to 'community/psmisc')
-rw-r--r--community/psmisc/APKBUILD24
-rw-r--r--community/psmisc/peekfd_lintl.patch30
2 files changed, 8 insertions, 46 deletions
diff --git a/community/psmisc/APKBUILD b/community/psmisc/APKBUILD
index 2deb2a57e3..bb6cb03249 100644
--- a/community/psmisc/APKBUILD
+++ b/community/psmisc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=psmisc
-pkgver=22.21
-pkgrel=2
+pkgver=23.0
+pkgrel=0
pkgdesc="A set of some small useful utilities that use the proc filesystem"
url="http://psmisc.sourceforge.net/"
arch="all"
@@ -9,31 +9,24 @@ license="BSD GPL"
depends=""
makedepends="gettext-dev libintl ncurses-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.gz
+source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.xz
include_limits.patch
musl_ptregs.patch
- peekfd_lintl.patch
"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$builddir"
- default_prepare
-}
-
build() {
cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
check() {
@@ -41,7 +34,6 @@ check() {
make check
}
-sha512sums="766aeb45687090b88b17176c5117a603e83fe92a13c013aea72c8ee80048adf02e18c7daa52ddfb8b2135f7c9a1bcae38896cdfb8d0158728d85a446c5e0d5ae psmisc-22.21.tar.gz
+sha512sums="334d625202fccd741363787c3f1d750515d63e2b5322b8ada5979144c8d841f505244c569bae9b63ce332aeace41b7caacd5354014c0301b56aca720a227f10d psmisc-23.0.tar.xz
63dea6a65c4cabcfa06d225950bc78fd6ac42f7445b8d10bde5e86dd8d96eb89823e486d7635b78562da058642f87289356c416225563a8e1ccfc2e32d81e884 include_limits.patch
-73dec9791e8cdb85cd3d9ef9be4d16e0fef481c6edc334ed9e954829444b1a92b87f7a3a2e6c1d09ac207bed828f214f5f2a95caa66540a7f2a6c58a6b8f6f2c musl_ptregs.patch
-ec84b84a02e48aed9f47a9efdd7ee4a4d409373751e9872e32c06912b506d9102a0526f244dcaff172598cd77e61344d38449a60181c2bbb010a674662e8f439 peekfd_lintl.patch"
+73dec9791e8cdb85cd3d9ef9be4d16e0fef481c6edc334ed9e954829444b1a92b87f7a3a2e6c1d09ac207bed828f214f5f2a95caa66540a7f2a6c58a6b8f6f2c musl_ptregs.patch"
diff --git a/community/psmisc/peekfd_lintl.patch b/community/psmisc/peekfd_lintl.patch
deleted file mode 100644
index 6d7ba1c227..0000000000
--- a/community/psmisc/peekfd_lintl.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Author: Breno Leitao <brenohl@br.ibm.com>
-Date: Thu Apr 6 14:03:00 2017 -0300
-
- pstree: Linking with libintl.
-
- Curently pstree does built, at least on ppc64le, because it does
- not have a explicit link against gettext, causing the following error:
-
- peekfd.o: In function `print_version':
- peekfd.c:(.text+0x160): undefined reference to `libintl_gettext'
- peekfd.c:(.text+0x18c): undefined reference to `libintl_gettext'
- peekfd.c:(.text+0x1ac): undefined reference to `libintl_gettext'
-
- peekfd depends on libint because of the following macro:
-
- #define _(String) gettext (String)
-
-Index: psmisc-22.21/src/Makefile.in
-===================================================================
---- psmisc-22.21.orig/src/Makefile.in
-+++ psmisc-22.21/src/Makefile.in
-@@ -131,7 +131,7 @@ killall_OBJECTS = $(am_killall_OBJECTS)
- killall_DEPENDENCIES =
- am_peekfd_OBJECTS = peekfd.$(OBJEXT)
- peekfd_OBJECTS = $(am_peekfd_OBJECTS)
--peekfd_LDADD = $(LDADD)
-+peekfd_LDADD = $(LDADD) -lintl
- am_prtstat_OBJECTS = prtstat.$(OBJEXT)
- prtstat_OBJECTS = $(am_prtstat_OBJECTS)
- prtstat_DEPENDENCIES =