aboutsummaryrefslogtreecommitdiffstats
path: root/community/pspg/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-06 17:42:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-06 17:42:50 +0200
commiteed7d6f7845bd798668cbd420344a35252b81350 (patch)
treea235f7a0680b713b04aa14d1f5cc0f32db3ce5f4 /community/pspg/APKBUILD
parentc564e3e860555811b03e1bd93cea748d407dea46 (diff)
downloadaports-eed7d6f7845bd798668cbd420344a35252b81350.tar.bz2
aports-eed7d6f7845bd798668cbd420344a35252b81350.tar.xz
community/pspg: move from testing
Diffstat (limited to 'community/pspg/APKBUILD')
-rw-r--r--community/pspg/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/pspg/APKBUILD b/community/pspg/APKBUILD
new file mode 100644
index 0000000000..fa2c5917c8
--- /dev/null
+++ b/community/pspg/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pspg
+pkgver=0.3
+pkgrel=0
+pkgdesc="A unix pager optimized for psql"
+url="https://github.com/okbob/pspg"
+arch="all"
+license="BSD-2-Clause"
+makedepends="ncurses-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./pspg -V
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="36719967bf9a74788d0f383ce38d9dde0d02e1f57b38d9957a93abfff5f4050531427db2a1de5ad8717a926ec37bd572ed2e2ad7155f6f77e61d57df935f5ec9 pspg-0.3.tar.gz"