aboutsummaryrefslogtreecommitdiffstats
path: root/community/pugixml
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-06-16 20:07:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-17 04:46:29 +0000
commiteb94e6d03d6288abb5adc3fc27c669bab6eb33df (patch)
tree12019c8b4711f3fac50e740185507befc7c11338 /community/pugixml
parent1e0f23fb1e26612dc94622b748f3b25e42c496cb (diff)
downloadaports-eb94e6d03d6288abb5adc3fc27c669bab6eb33df.tar.bz2
aports-eb94e6d03d6288abb5adc3fc27c669bab6eb33df.tar.xz
pugixml: move to community
Diffstat (limited to 'community/pugixml')
-rw-r--r--community/pugixml/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/pugixml/APKBUILD b/community/pugixml/APKBUILD
new file mode 100644
index 0000000000..7642122d40
--- /dev/null
+++ b/community/pugixml/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=pugixml
+pkgver=1.9
+pkgrel=0
+pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
+url="http://pugixml.org"
+arch="all"
+license="MIT"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f pugixml-1.9.tar.gz"