aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-decorator
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-19 06:22:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-19 06:22:05 +0000
commit2bb4604c65ea427220f8aeb7bd8ab7e1b3bae7d9 (patch)
treec668e9a4fa69fc50a600a04347ce9b2f6b5e5251 /community/py-decorator
parent6b93c3e18b1e1591ca109e76e77234f04a18e1e8 (diff)
downloadaports-2bb4604c65ea427220f8aeb7bd8ab7e1b3bae7d9.tar.bz2
aports-2bb4604c65ea427220f8aeb7bd8ab7e1b3bae7d9.tar.xz
community/py-decorator: upgrade to 4.1.1, added check()
Diffstat (limited to 'community/py-decorator')
-rw-r--r--community/py-decorator/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/py-decorator/APKBUILD b/community/py-decorator/APKBUILD
index acc799704f..0c036b1c15 100644
--- a/community/py-decorator/APKBUILD
+++ b/community/py-decorator/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-decorator
_pkgname=decorator
-pkgver=4.0.11
-pkgrel=1
+pkgver=4.1.1
+pkgrel=0
pkgdesc="Python Decorator module"
url="http://pypi.python.org/pypi/decorator"
arch="noarch"
@@ -14,10 +14,17 @@ subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -43,6 +50,4 @@ _py3() {
_py python3
}
-md5sums="73644c8f0bd4983d1b6a34b49adec0ae decorator-4.0.11.tar.gz"
-sha256sums="953d6bf082b100f43229cf547f4f97f97e970f5ad645ee7601d55ff87afdfe76 decorator-4.0.11.tar.gz"
-sha512sums="acce545d26c05ad03e4a3889214c3e94d1d47a9ccba42318ff8acb4d9384e676839fdcdb8d501a808f9332f532e4087a60398c273a58e07dfbc02f04f04af69c decorator-4.0.11.tar.gz"
+sha512sums="a072173cf20ff9a97df93da217e33d9671b90c32d3536e95f99d0783169ce0d41a3c7c601004b1b2717e503cf27fb8ab110156f641d6fc7a2b6adb46c9eb33f1 decorator-4.1.1.tar.gz"