aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-decorator
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 12:00:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 12:27:34 +0000
commitaaa3ef00220e8daaf6f3a6db5ba03a51d8896491 (patch)
tree85cfb160d3440a60d3ae8dd0e26a765683ab14ac /community/py-decorator
parentb23e701f4f66f0e0ef74f245e870230b0e3de52d (diff)
downloadaports-aaa3ef00220e8daaf6f3a6db5ba03a51d8896491.tar.bz2
aports-aaa3ef00220e8daaf6f3a6db5ba03a51d8896491.tar.xz
community/py-decorator: upgrade to 4.0.10, moved from testing, added python3 support and py2/py3 subpackages
Diffstat (limited to 'community/py-decorator')
-rw-r--r--community/py-decorator/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py-decorator/APKBUILD b/community/py-decorator/APKBUILD
new file mode 100644
index 0000000000..0ada3aefba
--- /dev/null
+++ b/community/py-decorator/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-decorator
+_pkgname=decorator
+pkgver=4.0.10
+pkgrel=0
+pkgdesc="Python Decorator module"
+url="http://pypi.python.org/pypi/decorator"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="python2-dev py-setuptools python3-dev"
+install=""
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+md5sums="434b57fdc3230c500716c5aff8896100 decorator-4.0.10.tar.gz"
+sha256sums="9c6e98edcb33499881b86ede07d9968c81ab7c769e28e9af24075f0a5379f070 decorator-4.0.10.tar.gz"
+sha512sums="612c2eafe16536c9b5eda07ea44999d868decbc38beb4207ab3f82325bafd346c431f9c9028f63bbf24573300a81dfb9446a51dee50bb34dc8b478088a541f73 decorator-4.0.10.tar.gz"