aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-gevent/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-11 20:29:49 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-11 20:30:31 +0200
commit2905100ac0ab2f0433fcffb71ed4a24f9bc895e6 (patch)
tree2cf449035da2a2923a0b0c1dcd6fff3a8042d6af /community/py-gevent/APKBUILD
parent4d3ad6d65815ddf21ea17b05479f3aef5199a455 (diff)
downloadaports-2905100ac0ab2f0433fcffb71ed4a24f9bc895e6.tar.bz2
aports-2905100ac0ab2f0433fcffb71ed4a24f9bc895e6.tar.xz
community/py-gevent: fix and improve abuild
Dependencies defined in split functions are needed in build time, so move them to global depends.
Diffstat (limited to 'community/py-gevent/APKBUILD')
-rw-r--r--community/py-gevent/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/py-gevent/APKBUILD b/community/py-gevent/APKBUILD
index 90846e9669..2881b51b2f 100644
--- a/community/py-gevent/APKBUILD
+++ b/community/py-gevent/APKBUILD
@@ -8,9 +8,9 @@ pkgdesc="Python library for seamless coroutine-based concurrency"
url="http://gevent.org/"
arch="all"
license="MIT"
-depends=""
+depends="py-greenlet"
makedepends="python2-dev py-setuptools python3-dev libevent-dev file"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://github.com/gevent/gevent/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -25,23 +25,23 @@ package() {
}
_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
_py2() {
- _py python2
replaces="$pkgname"
- depends="py2-greenlet"
+ depends="${depends//py-/py2-}"
+ _py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
- depends="py3-greenlet"
}