aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-greenlet/gcc-4.8-bugfix.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
commitbb160bb259b96da87176aa01213e1a75306069ae (patch)
tree24006feb1e93bf5de2f2247c181efba6556c442a /community/py-greenlet/gcc-4.8-bugfix.patch
parentbf9d181f3de29031973b61ebea07586c3139588c (diff)
downloadaports-bb160bb259b96da87176aa01213e1a75306069ae.tar.bz2
aports-bb160bb259b96da87176aa01213e1a75306069ae.tar.xz
community/py-greenlet: moved from testing, added python3 support, added py2/py3 subpackages
Diffstat (limited to 'community/py-greenlet/gcc-4.8-bugfix.patch')
-rw-r--r--community/py-greenlet/gcc-4.8-bugfix.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/py-greenlet/gcc-4.8-bugfix.patch b/community/py-greenlet/gcc-4.8-bugfix.patch
new file mode 100644
index 0000000000..1526f3eb18
--- /dev/null
+++ b/community/py-greenlet/gcc-4.8-bugfix.patch
@@ -0,0 +1,16 @@
+--- greenlet-0.4.0.orig/setup.py
++++ greenlet-0.4.0/setup.py
+@@ -2,12 +2,7 @@
+
+ import sys, os, glob, platform
+
+-# workaround segfaults on openbsd and RHEL 3 / CentOS 3 . see
+-# https://bitbucket.org/ambroff/greenlet/issue/11/segfault-on-openbsd-i386
+-# https://github.com/python-greenlet/greenlet/issues/4
+-if ((sys.platform == "openbsd4" and os.uname()[-1] == "i386")
+- or ("-with-redhat-3." in platform.platform() and platform.machine() == 'i686')):
+- os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "-Os")).lstrip()
++os.environ['CFLAGS'] = '-O0'
+
+ try:
+ if not (sys.modules.get("setuptools")