aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-gtkglext
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-21 23:00:12 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 23:00:12 +0200
commitc51ee158559212caa1dc73399fce586b0e0c049c (patch)
tree26b81da265c5707c9fcfa9ccc98bebb16626955c /community/py-gtkglext
parent973e86ae7f2d75c34f67d10a16db714e775b4dc8 (diff)
downloadaports-c51ee158559212caa1dc73399fce586b0e0c049c.tar.bz2
aports-c51ee158559212caa1dc73399fce586b0e0c049c.tar.xz
testing/py-gtkglext: move to community
Diffstat (limited to 'community/py-gtkglext')
-rw-r--r--community/py-gtkglext/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py-gtkglext/APKBUILD b/community/py-gtkglext/APKBUILD
new file mode 100644
index 0000000000..521c8f24e9
--- /dev/null
+++ b/community/py-gtkglext/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-gtkglext
+_pkgname=pygtkglext
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="GtkGLExt is an OpenGL extension to GTK+. Python bindings"
+url="https://projects.gnome.org/gtkglext/download.html#pygtkglext"
+arch="all"
+license="LGPL2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python-dev py-setuptools
+py-gtk-dev gtkglext-dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/gtkglext/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="dfbe2ceb05db9265a7d94b209fa8ad97 pygtkglext-1.1.0.tar.gz"
+sha256sums="9712c04c60bf6ee7d05e0c6a6672040095c2ea803a1546af6dfde562dc0178a3 pygtkglext-1.1.0.tar.gz"
+sha512sums="a9a872f85117e033cc165082fa2747624f25cd73c77e0c2487f08fe352c8d918cf0b30712e5d495ff2aea4def5fbf7ade0ab45fac0c0b48a9f4cbab70c63d420 pygtkglext-1.1.0.tar.gz"