aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-img2pdf
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-20 12:19:29 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-20 12:19:29 +0000
commit63361f374b5ee23b7a44386552041350920d876d (patch)
tree98a204c74515eff90525cb02ed0b0d7a8bda43d2 /community/py-img2pdf
parentf03c89eaa9e25be7a88f6a1780c9939b16daf655 (diff)
downloadaports-63361f374b5ee23b7a44386552041350920d876d.tar.bz2
aports-63361f374b5ee23b7a44386552041350920d876d.tar.xz
community/py-img2pdf: add check
Diffstat (limited to 'community/py-img2pdf')
-rw-r--r--community/py-img2pdf/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/py-img2pdf/APKBUILD b/community/py-img2pdf/APKBUILD
index ee406c9aaf..4b06e8a0d4 100644
--- a/community/py-img2pdf/APKBUILD
+++ b/community/py-img2pdf/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=py-img2pdf
pkgver=0.2.4
-pkgrel=0
+pkgrel=1
pkgdesc="Convert images to PDF via direct JPEG inclusion"
url="https://gitlab.mister-muffin.de/josch/img2pdf"
arch="noarch"
license="LGPL"
depends="py-pillow"
makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="py-pdfrw"
install=""
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://pypi.python.org/packages/7e/a2/4f06081f674920be757d894b4bab874e6a3b5227e730cb7618430b366e69/img2pdf-$pkgver.tar.gz"
@@ -20,6 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
package() {
mkdir -p "$pkgdir"
}