aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-ipaddr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-31 12:19:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-31 12:21:21 +0000
commitf9392f1f135867dc4abce1158e01d5d72275adc0 (patch)
tree859e37c9686d898ed81a3d01b858db7cbacaade8 /community/py-ipaddr
parente572e4ab43a4ddad00ac7f096b0ecafe66b7dba3 (diff)
downloadaports-f9392f1f135867dc4abce1158e01d5d72275adc0.tar.bz2
aports-f9392f1f135867dc4abce1158e01d5d72275adc0.tar.xz
community/py-ipaddr: py2/py3 subpackages, modernize, add test
Diffstat (limited to 'community/py-ipaddr')
-rw-r--r--community/py-ipaddr/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/py-ipaddr/APKBUILD b/community/py-ipaddr/APKBUILD
index 4526de27ee..8df568dd5f 100644
--- a/community/py-ipaddr/APKBUILD
+++ b/community/py-ipaddr/APKBUILD
@@ -2,32 +2,52 @@
pkgname=py-ipaddr
_pkgname=ipaddr
pkgver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python IP address manipulation library"
url="http://code.google.com/p/ipaddr-py"
arch="noarch"
license="Apache-2.0 PSF"
depends="python2"
-depends_dev=
-makedepends="$depends_dev"
-install=""
-subpackages=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- return 0
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- return 0
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 ipaddr_test.py
+ python3 ipaddr_test.py
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --root="$pkgdir"
+ python3 setup.py install --root="$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/$python* "$subpkgdir"/usr/lib/
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
}
sha512sums="5adb117c44e6e5dbdb9e96543aa7a34f35b4a4ec9baa163a25448058c34091bf4019d24f0250928291e4d4bc97dcdf75865daef739e2d94f98cc584e6e6c50dd ipaddr-2.2.0.tar.gz"