aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-ldap3
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-14 00:44:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-14 00:44:26 +0200
commitf5f96f2ca02c272c7313e0004bfdcb60d51349ea (patch)
tree50e3c94d2f1d2b2b646136c69bc6bbfe2b5ff6d8 /community/py-ldap3
parentdac587046be9355d6b2954a0d9927215697ea95f (diff)
downloadaports-f5f96f2ca02c272c7313e0004bfdcb60d51349ea.tar.bz2
aports-f5f96f2ca02c272c7313e0004bfdcb60d51349ea.tar.xz
community/py-ldap3: move from testing
Diffstat (limited to 'community/py-ldap3')
-rw-r--r--community/py-ldap3/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py-ldap3/APKBUILD b/community/py-ldap3/APKBUILD
new file mode 100644
index 0000000000..12dbb8b47d
--- /dev/null
+++ b/community/py-ldap3/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py-ldap3
+_pkgname=ldap3
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python client"
+url="https://github.com/cannatag/ldap3"
+arch="noarch"
+license="LGPL3"
+depends="py-asn1"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-$_pkgname:_subpackage py3-$_pkgname:_subpackage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cannatag/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # tests need running LDAP server
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local pyver="${subpkgname:2:1}"
+ local python="python$pyver"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python ${depends//py-/py$pyver-}"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5b67f8f2008f389a481d738070dc2ef445c85c70e4e2b1e5e8555763c6fae581802abdd085d56adbe42c22f49744af358850dc167407170080f7e3497b31963b py-ldap3-2.2.3.tar.gz"