aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-mechanize
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 14:16:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 14:21:35 +0000
commit30bce4f86f036808d552ba2cb35fa5cc7996e17f (patch)
tree58972c03d505a0f24ca79ffd520912cfde6e5146 /community/py-mechanize
parent69373ea27ae2a66b1c49f0e842ff4546e650a50b (diff)
downloadaports-30bce4f86f036808d552ba2cb35fa5cc7996e17f.tar.bz2
aports-30bce4f86f036808d552ba2cb35fa5cc7996e17f.tar.xz
community/py-mechanize: moved from testing
Diffstat (limited to 'community/py-mechanize')
-rw-r--r--community/py-mechanize/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py-mechanize/APKBUILD b/community/py-mechanize/APKBUILD
new file mode 100644
index 0000000000..e7e9576fe6
--- /dev/null
+++ b/community/py-mechanize/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-mechanize
+_pkgname=mechanize
+pkgver=0.2.5
+pkgrel=0
+pkgdesc="Stateful programmatic web browsing in Python"
+url="http://wwwsearch.sourceforge.net/mechanize/"
+arch="noarch"
+license="BSD ZPL"
+depends=
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="http://wwwsearch.sourceforge.net/$_pkgname/src/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -Dm644 COPYING.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/COPYING.txt
+}
+
+md5sums="32657f139fc2fb75bcf193b63b8c60b2 mechanize-0.2.5.tar.gz"