aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-ndg_httpsclient/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-15 15:37:24 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-15 15:37:24 +0000
commit7955cc68bae8dc0fc6cfc04eb2a37e2cc42259ab (patch)
tree0815a7f74c56e8212723ae5e4344bc6cfe68101c /community/py-ndg_httpsclient/APKBUILD
parent263f0590f7f3996a62a27c09081b7d45c2effc10 (diff)
downloadaports-7955cc68bae8dc0fc6cfc04eb2a37e2cc42259ab.tar.bz2
aports-7955cc68bae8dc0fc6cfc04eb2a37e2cc42259ab.tar.xz
community/py-ndg_httpsclient: modernize abuild
Diffstat (limited to 'community/py-ndg_httpsclient/APKBUILD')
-rw-r--r--community/py-ndg_httpsclient/APKBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/community/py-ndg_httpsclient/APKBUILD b/community/py-ndg_httpsclient/APKBUILD
index 263c240b73..7d2caeca4e 100644
--- a/community/py-ndg_httpsclient/APKBUILD
+++ b/community/py-ndg_httpsclient/APKBUILD
@@ -1,38 +1,27 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=py-ndg_httpsclient
+_pkgname=ndg_httpsclient
pkgver=0.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="HTTPS client implementation for httplib and urllib2 based on PyOpenSSL"
url="https://github.com/cedadev/ndg_httpsclient"
arch="noarch"
license="BSD"
-depends="py-openssl py-asn1"
-depends_dev=""
-makedepends="$depends_dev py-setuptools"
-install=""
-subpackages=""
-source="ndg_httpsclient-$pkgver.tar.gz::https://github.com/cedadev/ndg_httpsclient/archive/$pkgver.tar.gz"
+depends="py-openssl py-asn1 py-setuptools"
+makedepends="python2-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/cedadev/$_pkgname/archive/$pkgver.tar.gz"
-_builddir="$srcdir"/ndg_httpsclient-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="604ea4a27915cd338549c0c51f5ec3419a56f1c24472b2ecded7cb7e9939a73b3b93cdbe0b62ea27793949aa035253f767f330ffcd8d1c044ae3516db99dc59c ndg_httpsclient-0.4.4.tar.gz"