aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-paho-mqtt
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-12 12:35:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:00:05 +0200
commit65ff81915efdc52026767f4ae39c5beaf25671bf (patch)
tree69eb2ef3ea9eca2cbc7273614860e551089e50cf /community/py-paho-mqtt
parentb79b06689fde0fe4ba4659f14fd5aa2e15143b53 (diff)
downloadaports-65ff81915efdc52026767f4ae39c5beaf25671bf.tar.bz2
aports-65ff81915efdc52026767f4ae39c5beaf25671bf.tar.xz
testing/py-paho-mqtt: move to community
Diffstat (limited to 'community/py-paho-mqtt')
-rw-r--r--community/py-paho-mqtt/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/py-paho-mqtt/APKBUILD b/community/py-paho-mqtt/APKBUILD
new file mode 100644
index 0000000000..2ff5916afc
--- /dev/null
+++ b/community/py-paho-mqtt/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-paho-mqtt
+_pkgname=paho-mqtt
+pkgver=1.2
+pkgrel=0
+pkgdesc="A python MQTT version 3.1/3.1.1 client class"
+url="http://www.eclipse.org/paho/"
+arch="noarch"
+license="EPL"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="241150b3fcb920ddca4d33181f3238b1 paho-mqtt-1.2.tar.gz"
+sha256sums="9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f paho-mqtt-1.2.tar.gz"
+sha512sums="19ed426da15b156a54c472f712cec5326f98675a5605be666e1a4fece45ef9274192c8dc7fdd5a79d096e5c6ff754c3c5c408c9ef17c03d285bb72cd13dfe827 paho-mqtt-1.2.tar.gz"