aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-parsedatetime
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-15 17:57:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-15 17:57:48 +0000
commit0427d2932cd300cc4f782d25c242d5c98afcc4f2 (patch)
tree2671a6e1ba86283ccb0e08962dad8cbf95706061 /community/py-parsedatetime
parentbf2e352cb700ed566f0285970771702a013024c7 (diff)
downloadaports-0427d2932cd300cc4f782d25c242d5c98afcc4f2.tar.bz2
aports-0427d2932cd300cc4f782d25c242d5c98afcc4f2.tar.xz
community/py-parsedatetime: add check
Diffstat (limited to 'community/py-parsedatetime')
-rw-r--r--community/py-parsedatetime/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/py-parsedatetime/APKBUILD b/community/py-parsedatetime/APKBUILD
index ede6e68635..7f970c59ee 100644
--- a/community/py-parsedatetime/APKBUILD
+++ b/community/py-parsedatetime/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-parsedatetime
_pkgname=parsedatetime
pkgver=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Parse human-readable date/time strings"
url="https://github.com/bear/parsedatetime"
arch="noarch"
@@ -18,6 +18,11 @@ build() {
python2 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+}
+
package() {
cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"