aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-polib
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-06 10:40:50 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-06 10:41:13 +0000
commit7962188c9cef2789881984554d6f89ea02433667 (patch)
tree2643851d96914b6c05fd5dafea8d0db8f6b2316a /community/py-polib
parent6e26a52c3874952a802e5a7b0dc15920d2e6f696 (diff)
downloadaports-7962188c9cef2789881984554d6f89ea02433667.tar.bz2
aports-7962188c9cef2789881984554d6f89ea02433667.tar.xz
community/py-polib: upgrade to 1.0.8 and modernize
Diffstat (limited to 'community/py-polib')
-rw-r--r--community/py-polib/APKBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/community/py-polib/APKBUILD b/community/py-polib/APKBUILD
index c88e317725..26a8a74b80 100644
--- a/community/py-polib/APKBUILD
+++ b/community/py-polib/APKBUILD
@@ -2,40 +2,26 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-polib
_pkgname=polib
-pkgver=1.0.5
+pkgver=1.0.8
pkgrel=0
pkgdesc="A library to manipulate gettext files"
url="http://polib.readthedocs.org/en/latest/index.html"
arch="noarch"
license="MIT"
depends="python2"
-depends_dev=""
makedepends="python2-dev"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="c11eb8ce8e1b20fff71921402b3ce241 polib-1.0.5.tar.gz"
-sha256sums="c44236823eb6227b2fab8bd9e56632a649e67a80211f85a4a2e3c85c65c8acd9 polib-1.0.5.tar.gz"
-sha512sums="3dc02801bad76dec7a5c7a8d11e14294884bf4a8f45ed73b50b960617aa1600ee2f35261dd3ecde8b1deda1c897b0a55eaf2f0f755fe429df28b1acbd9c5e7d9 polib-1.0.5.tar.gz"
+sha512sums="6bcb8404a06e4e41e827ff947d13ea3165b7dbf0cd3f3f58c74ac1b49718a5d81f1a0ca0e59180928610b5eaefcc248aad9b8ca033978f580c141cd52405dc3f polib-1.0.8.tar.gz"