aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-prompt_toolkit
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:12:36 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:12:36 +0000
commitc7b5c3ccea006996eca31b4b96e14902ef1e71a0 (patch)
tree04e2ab2410157a548b2a11428a51993639125b22 /community/py-prompt_toolkit
parent94d4414a812c2339b36678aaa87fe430726fef6a (diff)
downloadaports-c7b5c3ccea006996eca31b4b96e14902ef1e71a0.tar.bz2
aports-c7b5c3ccea006996eca31b4b96e14902ef1e71a0.tar.xz
community/py-prompt_toolkit: moved from testing
Diffstat (limited to 'community/py-prompt_toolkit')
-rw-r--r--community/py-prompt_toolkit/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/py-prompt_toolkit/APKBUILD b/community/py-prompt_toolkit/APKBUILD
new file mode 100644
index 0000000000..c90b591a2b
--- /dev/null
+++ b/community/py-prompt_toolkit/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-prompt_toolkit
+_pkgname=prompt_toolkit
+pkgver=1.0.14
+pkgrel=0
+pkgdesc="Library for building powerful interactive command lines in Python"
+url="https://pypi.python.org/pypi/prompt_toolkit"
+arch="noarch"
+license="BSD"
+depends="py-six py-wcwidth"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="909bf50bf0095a8cc37581fc7384f9035eb9d6fd0d16a914e8912693476262cfe0b0c78643ba1c629bd907c861981a9740155927148fcff554446ebb4fd80959 py-prompt_toolkit-1.0.14.tar.gz"