aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pygit2
diff options
context:
space:
mode:
authorOlivier Mauras <olivier@mauras.ch>2016-09-15 06:19:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-15 14:01:34 +0200
commit227fd6cb8059bd9292fff1815dd78c1aa5eacdda (patch)
treeacf6920887231cbe36ad63e6375d5d9b790e772d /community/py-pygit2
parent14e530d4469e92ee23caebfb44ee9744db6100b9 (diff)
downloadaports-227fd6cb8059bd9292fff1815dd78c1aa5eacdda.tar.bz2
aports-227fd6cb8059bd9292fff1815dd78c1aa5eacdda.tar.xz
community/py-pygit2: move from testing
Diffstat (limited to 'community/py-pygit2')
-rw-r--r--community/py-pygit2/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/py-pygit2/APKBUILD b/community/py-pygit2/APKBUILD
new file mode 100644
index 0000000000..35b5282e7d
--- /dev/null
+++ b/community/py-pygit2/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Pierre-Gildas MILLON <pgmillon@gmail.com>
+# Maintainer: Olivier Mauras <olivier@mauras.ch>
+pkgname=py-pygit2
+_pkgname=pygit2
+pkgver=0.24.1
+pkgrel=1
+pkgdesc="Python bindings for libgit2"
+url="https://github.com/libgit2/pygit2"
+arch="noarch"
+license="GPLv2"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2-dev python3-dev py-setuptools py2-cffi py3-cffi py2-six py3-six
+ libgit2-dev libssh2-dev openssl-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libgit2/$_pkgname/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="py2-cffi py2-six"
+ _py python2
+}
+
+_py3() {
+ depends="py3-cffi py3-six"
+ _py python3
+}
+
+_py() {
+ local python=$1
+ arch="all"
+ pkgdesc="$pkgdesc - $python"
+ depends="libgit2 $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+}
+
+md5sums="d9915e3f8a7da65af3ea70f5bc02967d py-pygit2-0.24.1.tar.gz"
+sha256sums="e62bd35c39b4dec64a8a35ab688e98352603c21a6b254473763868a45110fb47 py-pygit2-0.24.1.tar.gz"
+sha512sums="a6ac980d20f9342cefbb3646cef0b99b75037813d11e64797a62c8df5f0cc2d4a8397c266caf25f49d9c2e2cb47b0087e38e64527ef59385ddb00023cb04ab0f py-pygit2-0.24.1.tar.gz"