aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pygraphviz/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-20 15:06:16 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 07:26:12 +0000
commit1e0fa496054b8808e64a9cb033cbc54fc15b707a (patch)
tree886ec04143f510941c9be8bab90cd1e8c1175188 /community/py-pygraphviz/APKBUILD
parent48a68a65b7c71310bd794686ea97f15b3995fef6 (diff)
downloadaports-1e0fa496054b8808e64a9cb033cbc54fc15b707a.tar.bz2
aports-1e0fa496054b8808e64a9cb033cbc54fc15b707a.tar.xz
community/py-pygraphviz: rename package due to conflict with graphviz
https://github.com/xflr6/graphviz
Diffstat (limited to 'community/py-pygraphviz/APKBUILD')
-rw-r--r--community/py-pygraphviz/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py-pygraphviz/APKBUILD b/community/py-pygraphviz/APKBUILD
new file mode 100644
index 0000000000..c1c2351bbd
--- /dev/null
+++ b/community/py-pygraphviz/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py-pygraphviz
+pkgver=1.3
+pkgrel=0
+pkgdesc="Python interface to Graphviz"
+url="https://pygraphviz.github.io/"
+arch="all"
+license="BSD"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev graphviz-dev py-setuptools"
+subpackages="$pkgname-doc"
+source="https://github.com/pygraphviz/pygraphviz/archive/pygraphviz-$pkgver.tar.gz"
+
+builddir="$srcdir/pygraphviz-pygraphviz-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="889574a735e8a9ff696dc38d59baebe44ad2b8b9ce7012e961e48a6f2974d4dfaf54a4dbf28f6c79b9bfcf71499aceec0ea618bf508399efda6583bde3b55107 pygraphviz-1.3.tar.gz"