aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-requests-toolbelt
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-03 10:59:56 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-03 11:00:09 +0000
commit3ba28189f2c0362c43373c7cf9f4ef655b7a14f8 (patch)
tree65d59b8c1ba3e489e3c2ea5051f89305cf0d29e3 /community/py-requests-toolbelt
parent85734a6faa0cfe63622465533d9131f06075d3e2 (diff)
downloadaports-3ba28189f2c0362c43373c7cf9f4ef655b7a14f8.tar.bz2
aports-3ba28189f2c0362c43373c7cf9f4ef655b7a14f8.tar.xz
community/py-requests-toolbelt: move from testing
certbot requires py-requests-toolbelt to run
Diffstat (limited to 'community/py-requests-toolbelt')
-rw-r--r--community/py-requests-toolbelt/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py-requests-toolbelt/APKBUILD b/community/py-requests-toolbelt/APKBUILD
new file mode 100644
index 0000000000..f432b48dbb
--- /dev/null
+++ b/community/py-requests-toolbelt/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=py-requests-toolbelt
+_pkgname=toolbelt
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="Useful classes and functions to be used with python-requests"
+url="https://github.com/requests/toolbelt"
+arch="noarch"
+license="Apache-2.0"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/requests/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ($python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="55bf93d386442f5deb81eabd85812ffd49e98ff88c0bb96e15271efd84deb7c5d854a2cdc81c989a7d74870e8a218fc968d080052d9ca7cd9733a2378ea9c2f5 py-requests-toolbelt-0.8.0.tar.gz"