aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-qt5
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 12:26:36 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:04 +0000
commit12ae3bd2b9c54f97ca9ab7718bd197ff342ad5be (patch)
tree789c31d36517bc982e4dcf69a7fd22e09a1d3c41 /community/py3-qt5
parent8656c36008a671cf2ea1919573b5f81b21290bc1 (diff)
downloadaports-12ae3bd2b9c54f97ca9ab7718bd197ff342ad5be.tar.bz2
aports-12ae3bd2b9c54f97ca9ab7718bd197ff342ad5be.tar.xz
community/py3-qt5: upgrade to 5.7, moved from testing
Diffstat (limited to 'community/py3-qt5')
-rw-r--r--community/py3-qt5/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/py3-qt5/APKBUILD b/community/py3-qt5/APKBUILD
new file mode 100644
index 0000000000..775b79abd0
--- /dev/null
+++ b/community/py3-qt5/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-qt5
+_pkgname=PyQt
+pkgver=5.7
+pkgrel=0
+pkgdesc="A set of Python 3 bindings for the Qt toolkit"
+url="http://riverbankcomputing.co.uk/software/pyqt/intro"
+arch="all"
+license="GPL2+"
+depends="py3-sip"
+makedepends="python3-dev py-dbus-dev qt5-qtbase-dev py3-sip-dev libx11-dev qt5-qtsvg-dev"
+subpackages=""
+install=""
+source="http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.zip"
+
+builddir="${srcdir}/PyQt5_gpl-${pkgver}"
+build() {
+ cd "$builddir"
+ python3 configure.py \
+ --confirm-license \
+ --qmake /usr/lib/qt5/bin/qmake \
+ -v /usr/share/sip \
+ --qsci-api
+ # Thanks Gerardo for the rpath fix
+ find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+ make || return 1
+}
+
+package(){
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install || return 1
+}
+
+md5sums="43568c2798db2d18a040fd215fcba2f6 PyQt5_gpl-5.7.zip"
+sha256sums="1607a90af2c2e944e2aebc7ba4a7ec9c327ec78afbaf3a5eab2b6c65cd81d1e5 PyQt5_gpl-5.7.zip"
+sha512sums="2f5978e6182f517711b2d37b4ac45e5460fbbc8706a3a07510c82cf9d1d8d18ac1588b492dceed0b5b37aee6dfc4e4aeed736531d885e583401ac89e1f1fbd93 PyQt5_gpl-5.7.zip"