aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-sip
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-17 14:29:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-17 14:32:04 +0000
commit745cf9d3738122e7d0f3ae17db2bfb8d94799b5a (patch)
tree0f847d4b7bd9f86d31095db96af861f559b6d092 /community/py3-sip
parentdbe6ef6e13bb51a4de731a69878ba1e14472976d (diff)
downloadaports-745cf9d3738122e7d0f3ae17db2bfb8d94799b5a.tar.bz2
aports-745cf9d3738122e7d0f3ae17db2bfb8d94799b5a.tar.xz
community/py3-sip: upgrade to 4.19.2, modernize APKBUILD
Diffstat (limited to 'community/py3-sip')
-rw-r--r--community/py3-sip/APKBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/community/py3-sip/APKBUILD b/community/py3-sip/APKBUILD
index 631ddd1d57..8168201b0b 100644
--- a/community/py3-sip/APKBUILD
+++ b/community/py3-sip/APKBUILD
@@ -2,38 +2,33 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-sip
_pkgname=sip
-pkgver=4.18.1
+pkgver=4.19.2
pkgrel=0
pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries. Python 3 package."
url="http://www.riverbankcomputing.com/software/sip/"
arch="all"
license="custom:sip"
-depends=""
-depends_dev=""
makedepends="python3-dev"
-install=""
+options="!check"
replaces="py-sip"
subpackages="$pkgname-dev"
source="http://sourceforge.net/projects/pyqt/files/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
python3 configure.py
make CC="${CC:-gcc}" \
CXX="${CXX:-g++}" \
CFLAGS="$CFLAGS -fPIC" \
- CXXFLAGS="$CXXFLAGS" \
- || return 1
+ CXXFLAGS="$CXXFLAGS"
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
}
-md5sums="9d664c33e8d0eabf1238a7ff44a399e9 sip-4.18.1.tar.gz"
-sha256sums="9bce7a2dbf7f105bf68ad1bab58eebc0ce33087ec40396da756463f086ffa290 sip-4.18.1.tar.gz"
-sha512sums="c4277fa113bf5e28d8a19388f160456654e4ccbbc2adc1209677e95e1efad427ce641ef09875ec0a59e555578986671261dd4c3ac52c673b5803f188fc311222 sip-4.18.1.tar.gz"
+sha512sums="6f14f387a899130cf15820d2b58d937d134a2eefd53c65a82af060e88a6ca039442b21f822880c4a3742d6f26328853a552239873c55d7b22de62a6cc5037b3e sip-4.19.2.tar.gz"