aboutsummaryrefslogtreecommitdiffstats
path: root/community/rancid
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:34:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:34:08 +0000
commitbcd5ff54517890cb120d6884fb5660bc465b0236 (patch)
tree8ef0f6e44c8b8b4bb3ec454067e1c946c21c7535 /community/rancid
parent749d2e684cbb034cff718ca48dd8beb2e99151b6 (diff)
downloadaports-bcd5ff54517890cb120d6884fb5660bc465b0236.tar.bz2
aports-bcd5ff54517890cb120d6884fb5660bc465b0236.tar.xz
community/rancid: moved from testing
Diffstat (limited to 'community/rancid')
-rw-r--r--community/rancid/APKBUILD64
-rw-r--r--community/rancid/rancid-2.3.2-conf.patch20
-rw-r--r--community/rancid/rancid.logrotate8
-rw-r--r--community/rancid/rancid.pre-install6
4 files changed, 98 insertions, 0 deletions
diff --git a/community/rancid/APKBUILD b/community/rancid/APKBUILD
new file mode 100644
index 0000000000..5a2909c9f7
--- /dev/null
+++ b/community/rancid/APKBUILD
@@ -0,0 +1,64 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=rancid
+pkgver=3.4.1
+pkgrel=1
+pkgdesc="A Cisco config Differ"
+url="http://www.shrubbery.net/rancid/"
+arch="all"
+license="BSD with advertising"
+depends="expect perl logrotate iputils"
+depends_dev=""
+makedepends="$depends_dev openssh-client cvs subversion"
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc"
+pkgusers="rancid"
+pkggroups="netadm"
+source="ftp://ftp.shrubbery.net/pub/rancid/rancid-$pkgver.tar.gz
+ rancid-2.3.2-conf.patch
+ rancid.logrotate"
+
+_builddir="$srcdir"/rancid-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/rancid \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-conf-install \
+ --with-svn \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 "$srcdir"/rancid.logrotate \
+ "$pkgdir"/etc/logrotate.d/rancid || return 1
+ install -d -m 0755 -o rancid -g netadm "$pkgdir"/var/rancid
+ install -d -m 0755 -o rancid -g netadm "$pkgdir"/var/log/rancid
+ install -d -m 0755 -o rancid -g netadm "$pkgdir"/var/log/rancid/old
+}
+
+md5sums="b9dba9011d9a47b9dc4fae9965cd61d8 rancid-3.4.1.tar.gz
+bd2e1e80348d88a11ee838ff40270039 rancid-2.3.2-conf.patch
+97c733c7420fe140b51a75d676431daf rancid.logrotate"
+sha256sums="572964f01969bd18b198110a75013ec31ec2aba6ca582ebf6cd208c422fe3bfe rancid-3.4.1.tar.gz
+c98a96e0c3a16a228a83e7570ca1adc27e73cdcd4cc718aa0e2956454b564e9f rancid-2.3.2-conf.patch
+5459497b88b9bfef122608a9a7fd70b23cfdf558617b62ab40cac5bc32226ad0 rancid.logrotate"
+sha512sums="d11dc471d3f13c15faa260fc2b074fe5fad5959b673d2fe97c2e233bf339cfc148ae80b080253513261a799f5c1913fdc848de1fc1f2db0e787175531704b228 rancid-3.4.1.tar.gz
+dbebdecb80483fff45cfdd7a541805f45ee4e180d47a79ce9b71c5aad012d6e782c9a9d29f1de0fc2b89642aeecfc90dfddb86a1e11564e30683fa55e7009d76 rancid-2.3.2-conf.patch
+aefbdeb99acd6840ab7fe75602b4cec2ed07a4eb24d073a951feef22ab7e56aff098bed7e0ca042c977218a2311465780aa5e6203507da8ab43e132df9a21795 rancid.logrotate"
diff --git a/community/rancid/rancid-2.3.2-conf.patch b/community/rancid/rancid-2.3.2-conf.patch
new file mode 100644
index 0000000000..e68064ebf6
--- /dev/null
+++ b/community/rancid/rancid-2.3.2-conf.patch
@@ -0,0 +1,20 @@
+--- ./etc/rancid.conf.sample.in.orig 2012-07-22 15:13:09.357012183 +0200
++++ ./etc/rancid.conf.sample.in 2012-07-22 15:13:51.797481604 +0200
+@@ -22,7 +22,7 @@
+ TMPDIR=/tmp; export TMPDIR
+ # Be careful changing this, it affects CVSROOT below. It should be a FQPN, not
+ # relative.
+-BASEDIR=@localstatedir@; export BASEDIR
++BASEDIR=/var/rancid; export BASEDIR
+ PATH=@bindir@:@ENV_PATH@; export PATH
+ # Location of the CVS/SVN repository. Be careful changing this.
+ # If RCSSYS is svn, this can be:
+@@ -34,7 +34,7 @@
+ # commands can run, e.g. by running rancid-cvs after installation.
+ CVSROOT=$BASEDIR/CVS; export CVSROOT
+ # Location of log files produced by rancid-run(1).
+-LOGDIR=$BASEDIR/logs; export LOGDIR
++LOGDIR=/var/log/rancid; export LOGDIR
+ #
+ # Select which RCS system to use, "cvs" (default) or "svn". Do not change
+ # this after CVSROOT has been created with rancid-cvs. Changing between these
diff --git a/community/rancid/rancid.logrotate b/community/rancid/rancid.logrotate
new file mode 100644
index 0000000000..3638b8b225
--- /dev/null
+++ b/community/rancid/rancid.logrotate
@@ -0,0 +1,8 @@
+/var/log/rancid/* {
+ weekly
+ rotate 1
+ notifempty
+ missingok
+ compress
+ olddir old
+}
diff --git a/community/rancid/rancid.pre-install b/community/rancid/rancid.pre-install
new file mode 100644
index 0000000000..f98f571bfe
--- /dev/null
+++ b/community/rancid/rancid.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S netadm 2>/dev/null
+adduser -S -D -h /var/rancid -s /bin/sh -G netadm -g rancid rancid 2>/dev/null
+
+exit 0