aboutsummaryrefslogtreecommitdiffstats
path: root/community/raptor2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 08:11:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commitf16d76810d87280a235f5f4d8b120b9cdadae27d (patch)
tree432bc829fd8b38d2cfae4a53a84d0691fddb9eef /community/raptor2
parent1e701356503b6fa20fc05e306d825b23f1b731a6 (diff)
downloadaports-f16d76810d87280a235f5f4d8b120b9cdadae27d.tar.bz2
aports-f16d76810d87280a235f5f4d8b120b9cdadae27d.tar.xz
community/raptor2: moved from main
Diffstat (limited to 'community/raptor2')
-rw-r--r--community/raptor2/APKBUILD46
-rw-r--r--community/raptor2/raptor-curl.patch12
2 files changed, 58 insertions, 0 deletions
diff --git a/community/raptor2/APKBUILD b/community/raptor2/APKBUILD
new file mode 100644
index 0000000000..1faafd7306
--- /dev/null
+++ b/community/raptor2/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=raptor2
+pkgver=2.0.14
+pkgrel=0
+pkgdesc="RDF parser toolkit for Redland"
+url="http://www.librdf.org/raptor"
+arch="all"
+license="GPL"
+depends=
+depends_dev="curl-dev libxml2-dev libxslt-dev yajl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.librdf.org/source/raptor2-$pkgver.tar.gz"
+
+_builddir="$srcdir"/raptor2-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d3e0b43866197a5367b781b25510f728 raptor2-2.0.14.tar.gz"
+sha256sums="cb447b7c684cbe60f1266d622691fd20fdcf7b91f4a470c6de5fc8e8961df1b2 raptor2-2.0.14.tar.gz"
+sha512sums="399e23f2c549df8f1d709d67129d3fcf7899a8cdcdd8071c165f2b4106f397cce05fc69a6d7b176857011bf95723c0909b6510eded12f82217f89925bc1ba7c2 raptor2-2.0.14.tar.gz"
diff --git a/community/raptor2/raptor-curl.patch b/community/raptor2/raptor-curl.patch
new file mode 100644
index 0000000000..e47a496c4c
--- /dev/null
+++ b/community/raptor2/raptor-curl.patch
@@ -0,0 +1,12 @@
+diff --git a/src/raptor_internal.h b/src/raptor_internal.h
+index f7944db..d9c2068 100644
+--- a/src/raptor_internal.h
++++ b/src/raptor_internal.h
+@@ -852,7 +852,6 @@ int raptor_utf8_is_nfc(const unsigned char *input, size_t length);
+
+ #ifdef RAPTOR_WWW_LIBCURL
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #endif
+