aboutsummaryrefslogtreecommitdiffstats
path: root/community/rawtherapee
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-02-28 11:12:26 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-02-28 11:13:23 +0000
commit1b2e900498ba400f596f99fba0c8dfde62e7aca2 (patch)
tree5f036a28aa7f44bac351e75d08d273b2014ec75f /community/rawtherapee
parente35c6a193564928cbc3795a8428655234fa58b12 (diff)
downloadaports-1b2e900498ba400f596f99fba0c8dfde62e7aca2.tar.bz2
aports-1b2e900498ba400f596f99fba0c8dfde62e7aca2.tar.xz
community/rawtherapee: move stuff in prepare()
Modernize APKBUILD
Diffstat (limited to 'community/rawtherapee')
-rw-r--r--community/rawtherapee/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
index c1c13420ad..75db95d4bc 100644
--- a/community/rawtherapee/APKBUILD
+++ b/community/rawtherapee/APKBUILD
@@ -3,7 +3,7 @@
pkgname=rawtherapee
pkgver=5.4_rc2
_pkgver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
url="http://rawtherapee.com"
arch="x86 x86_64 ppc64le"
@@ -17,13 +17,16 @@ subpackages="$pkgname-doc $pkgname-dbg"
source="$pkgname-$pkgver.tar.xz::http://rawtherapee.com/shared/source/rawtherapee-$_pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$_pkgver
-build() {
+prepare() {
mkdir -p "$builddir"/build
cd "$builddir"/build
export CXXFLAGS="$CXXFLAGS -std=c++11"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- .. || return 1
- make || return 1
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+build() {
+ cd "$builddir"/build
+ make
}
package() {