aboutsummaryrefslogtreecommitdiffstats
path: root/community/redsocks
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:55:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:55:02 +0000
commit27563f5bfee734648c82e9e9a8e19a7fe545e7fe (patch)
treec5e827b6d2ce9fd9ac26cbb857bcd786205912c6 /community/redsocks
parent9d83c6aee5d2f16582dfd678b7e2245bcea3c290 (diff)
downloadaports-27563f5bfee734648c82e9e9a8e19a7fe545e7fe.tar.bz2
aports-27563f5bfee734648c82e9e9a8e19a7fe545e7fe.tar.xz
community/redsocks: moved from testing
Diffstat (limited to 'community/redsocks')
-rw-r--r--community/redsocks/APKBUILD35
-rw-r--r--community/redsocks/redsocks.initd35
2 files changed, 70 insertions, 0 deletions
diff --git a/community/redsocks/APKBUILD b/community/redsocks/APKBUILD
new file mode 100644
index 0000000000..8656b58322
--- /dev/null
+++ b/community/redsocks/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=redsocks
+pkgver=0.4
+pkgrel=1
+pkgdesc="Transparent redirector of any TCP connection to proxy using your firewall"
+url="http://darkk.net.ru/redsocks"
+arch="all"
+license="Apache-2.0"
+depends=""
+makedepends="libevent-dev iptables-dev"
+install=""
+subpackages=""
+source="redsocks-$pkgver.zip::https://github.com/darkk/$pkgname/archive/release-$pkgver.zip
+ redsocks.initd"
+builddir="$srcdir"/$pkgname-release-$pkgver
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 redsocks "$pkgdir/usr/bin/redsocks"
+ install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -Dm644 redsocks.conf.example "$pkgdir"/etc/$pkgname/redsocks.conf
+}
+
+md5sums="1f29854b20d931f2f4590a3c832ee3ec redsocks-0.4.zip
+ebf676a98e9798731c621900ad50e1bf redsocks.initd"
+sha256sums="eedb7fd6cb00b207938c463c5eda63aae7cec1a43715b7e1c0106bd6fdaea729 redsocks-0.4.zip
+42f7d2318b8e6e2601fecb8310f0e9d1b6b4ed442b872b4cdea406e84e154b5b redsocks.initd"
+sha512sums="bd88684f2964a7f94b6965f445379479f2a70938490a28bcacbeafcad911cbbf40a640cf37ff5fcbc0475075dbf1858bbb905cd5db9519ff76d900e9b35e1242 redsocks-0.4.zip
+e2da5e1c5025a46c1f64daec4017d34a700d9d269cc463ef9395989c73d9aeefad222409f6cdfba92742011c4ef4a9edef554706f3353dfd0f7bc526247551c5 redsocks.initd"
diff --git a/community/redsocks/redsocks.initd b/community/redsocks/redsocks.initd
new file mode 100644
index 0000000000..592f19385c
--- /dev/null
+++ b/community/redsocks/redsocks.initd
@@ -0,0 +1,35 @@
+#!/sbin/openrc-run
+
+description="Transparent socks redirector"
+
+CFGFILE="/etc/redsocks/${SVCNAME}.conf"
+PIDFILE="/var/run/${SVCNAME}.pid"
+
+depend() {
+ need localmount net
+ use dns logger
+ after bootmisc firewall
+}
+
+checkconfig() {
+ /usr/bin/redsocks -t -c ${CFGFILE}
+ if [ "$?" -gt 0 ]; then
+ eerror "Problem on configuration file ${CFGFILE}"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/bin/redsocks --pidfile "${PIDFILE}" \
+ -- -c "${CFGFILE}" -p "${PIDFILE}"
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/bin/redsocks --pidfile "${PIDFILE}"
+ eend $?
+}