aboutsummaryrefslogtreecommitdiffstats
path: root/community/rest
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:33:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:05 +0000
commit9ce6e8abe90b9ec6b89b56072cd45c308a14e8fa (patch)
tree0e74e253464528e6eae9888eca7108a65499e423 /community/rest
parent409d46bdce6e4179aa3802f70685c9f1b3927f33 (diff)
downloadaports-9ce6e8abe90b9ec6b89b56072cd45c308a14e8fa.tar.bz2
aports-9ce6e8abe90b9ec6b89b56072cd45c308a14e8fa.tar.xz
main/rest: move to community
Diffstat (limited to 'community/rest')
-rw-r--r--community/rest/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/rest/APKBUILD b/community/rest/APKBUILD
new file mode 100644
index 0000000000..1fe6946517
--- /dev/null
+++ b/community/rest/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rest
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="A library for access to RESTful web services"
+url="http://www.gnome.org"
+arch="all"
+license="LGPL-2.0-or-later"
+depends_dev="libsoup-dev gobject-introspection-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/rest/${pkgver%.*}/rest-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --enable-introspection \
+ --without-gnome
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+
+}
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="824a341db3827e4360abe03e33735918c68913c70d797699ef74271080a1985872006ec70fd994dc8fa3fbfef417e6fe979883c11286512d0ce623b8368e40c3 rest-0.8.1.tar.xz"