aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-27 14:21:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-27 15:30:37 +0200
commit5fe974d357db25cfea207d327fe3ad92dcedaca8 (patch)
treeb4a105496ef13474907a1cd39aedb8054558172c /community/roundcubemail
parent91498e87a2d6a142d639fabf5d7f9f583483a041 (diff)
downloadaports-5fe974d357db25cfea207d327fe3ad92dcedaca8.tar.bz2
aports-5fe974d357db25cfea207d327fe3ad92dcedaca8.tar.xz
community/roundcubemail: add customized default config
Diffstat (limited to 'community/roundcubemail')
-rw-r--r--community/roundcubemail/APKBUILD6
-rw-r--r--community/roundcubemail/config.inc.php145
2 files changed, 151 insertions, 0 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 4d4963e8d5..a72dadb73d 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -42,6 +42,7 @@ source="https://github.com/roundcube/$pkgname/releases/download/$pkgver/$pkgname
fix-dirs.patch
config-session_key.patch
config-disable-remote-spellcheck.patch
+ config.inc.php
fpm-pool.conf
$pkgname.confd
$pkgname.logrotate
@@ -114,9 +115,13 @@ package() {
mv ./$_destdir/config ./etc/roundcube
mkdir ./etc/roundcube/plugins
+ install -m 644 -o roundcube -g roundcube \
+ "$srcdir"/config.inc.php ./etc/roundcube/
+
local file; for file in CHANGELOG INSTALL README.md UPGRADING; do
_mv ./$_destdir/$file ./usr/share/doc/roundcube/
done
+ _mv ./etc/roundcube/config.inc.php.sample ./usr/share/doc/roundcube/
_mv ./$_destdir/LICENSE ./usr/share/licenses/roundcube/
install -m 755 -D "$srcdir"/$pkgname.daily ./etc/periodic/daily/$pkgname
@@ -198,6 +203,7 @@ sha512sums="fc1627d4b539742524c43b3faaa8cb5d64f934ad03f7cf8a461580a3a38dccb11140
d205ba8442870b26f93fb287e7fe2bd1a452ea534823869b7ef299e2dca52d64c8a3fdc9a44bd3bc731c1e400efcf745c1866974e3b908e4e54d05b47b835f3e fix-dirs.patch
7c4b88da4d2baa53d247dcb7b130d564954a04611c13f2770f45924fafab2a0e98f8dd078cabc87f3eddd0ab03f3ca48a48f27a462676354af22566cb19d220b config-session_key.patch
e46cdded33114ee7dae671d936cc41551168df29778dbf18f848a4f0eb0738a54c0751a5689716ba126ac256f2a50284afdcde542a42827003d6ba89af94f064 config-disable-remote-spellcheck.patch
+1ed41e25b5045849a35eb0cb89b6779378773edcc6395b7390d9d919c956aaa487a4cc0dfa41b250129ae40444b93a3c20738101f784f17a25f7aba1d95de047 config.inc.php
c88d609e94c212215a24f54d2a2cb800d4a382b1044e0c875416bdda6a4e6c0cb896675918e8d24f3ed9e1b677d526d61f3ee1564cb870f674dac687696e8ba4 fpm-pool.conf
acaa76bfbba6117172a02ad11e39f9b55838895104e75180b057f647156c04fd2e44ac695a333f2332691d19bac5ef8afaca1f89ad409800b19f78afbb40aecb roundcubemail.confd
2e923d556d46bd7dc9360c3190fa1c5864bd0385fadaf73dacee5780cdad94ce09bc8462ccc05c3ca70bc7890aa1f1b3314a3cc831eab9d5b06c5a463483ccf7 roundcubemail.logrotate
diff --git a/community/roundcubemail/config.inc.php b/community/roundcubemail/config.inc.php
new file mode 100644
index 0000000000..7307c38cfb
--- /dev/null
+++ b/community/roundcubemail/config.inc.php
@@ -0,0 +1,145 @@
+<?php
+
+/*
+ +-----------------------------------------------------------------------+
+ | Local configuration for the Roundcube Webmail installation. |
+ | |
+ | This is a samle configuration file only containing the most common |
+ | configuration options. You may copy more options from |
+ | defaults.inc.php to this file to override the defaults. |
+ | |
+ | This file is provided by Alpine Linux. |
+ +-----------------------------------------------------------------------+
+*/
+
+$config = array();
+
+// ----------------------------------
+// SQL DATABASE
+// ----------------------------------
+
+// Database connection string (DSN) for read+write operations.
+// Format (compatible with PEAR MDB2): db_provider://user:password@host/database
+// Currently supported db_providers: mysql, pgsql, sqlite, mssql, sqlsrv.
+// IMPORTANT: Install package for the DB of your choice, e.g. `apk add roundcubemail-pgsql`.
+$config['db_dsnw'] = 'pgsql://roundcube:top-secret@localhost/roundcube';
+
+
+// ----------------------------------
+// IMAP
+// ----------------------------------
+
+// The IMAP host chosen to perform the log-in.
+// Leave blank to show a textbox at login, give a list of hosts
+// to display a pulldown menu or set one host as string.
+// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
+//$config['default_host'] = 'localhost';
+
+// TCP port used for IMAP connections
+//$config['default_port'] = 143;
+
+// IMAP connection timeout, in seconds. Default: 0 (use default_socket_timeout)
+//$config['imap_timeout'] = 0;
+
+
+// ----------------------------------
+// SMTP
+// ----------------------------------
+
+// SMTP server host (for sending mails).
+// Enter hostname with prefix tls:// to use STARTTLS, or use
+// prefix ssl:// to use the deprecated SSL over SMTP (aka SMTPS).
+//$config['smtp_server'] = 'localhost';
+
+// SMTP port (default is 25; use 587 for STARTTLS or 465 for the
+// deprecated SSL over SMTP (aka SMTPS)).
+//$config['smtp_port'] = 25;
+
+// SMTP username (if required) if you use %u as the username Roundcube
+// will use the current username for login.
+//$config['smtp_user'] = '%u';
+
+// SMTP password (if required) if you use %p as the password Roundcube
+// will use the current user's password for login.
+//$config['smtp_pass'] = '%p';
+
+
+// ----------------------------------
+// SYSTEM
+// ----------------------------------
+
+// Provide an URL where a user can get support for this Roundcube installation.
+// PLEASE DO NOT LINK TO THE ROUNDCUBE.NET WEBSITE HERE!
+//$config['support_url'] = '';
+
+// Allow browser-autocompletion on login form.
+// 0 - disabled, 1 - username and host only, 2 - username, host, password
+//$config['login_autocomplete'] = 0;
+
+// Session lifetime in minutes.
+//$config['session_lifetime'] = 10;
+
+// Name your service. This is displayed on the login screen and in the window title.
+//$config['product_name'] = 'Roundcube Webmail';
+
+// Load the key from /etc/roundcube/session_key (random key generated on install).
+// This key is used to encrypt the users imap password which is stored
+// in the session record (and the client cookie if remember password is enabled).
+// It must be exactly 24 chars long.
+$config['des_key'] = trim(file(RCMAIL_CONFIG_DIR . '/session_key')[0]);
+
+// Password charset.
+// Defaults to ISO-8859-1 for backward compatibility
+$config['password_charset'] = 'UTF-8';
+
+// Mimetypes supported by the browser.
+// Attachments of these types will open in a preview window.
+// Either a comma-separated list or an array: 'text/plain,text/html,text/xml,image/jpeg,image/gif,image/png,application/pdf'.
+$config['client_mimetypes'] = 'text/plain,text/html,image/jpeg,image/gif,image/png,application/pdf';
+
+// List of active plugins (in plugins/ directory).
+//$config['plugins'] = array();
+
+
+// ----------------------------------
+// USER INTERFACE
+// ----------------------------------
+
+// Make use of the built-in spell checker.
+//$config['enable_spellcheck'] = false;
+
+// Set the spell checking engine. Possible values:
+// - 'googie' - don't use this, it sends everything you type to a remote service!
+// - 'pspell' - requires the PHP Pspell module and aspell installed (apk add php7-pspell)
+// - 'enchant' - requires the PHP Enchant module (apk add php7-enchant)
+// - 'atd' - install your own After the Deadline server or check with the people at http://www.afterthedeadline.com before using their API
+//$config['spellcheck_engine'] = 'pspell';
+
+// Enables files upload indicator. Requires APC installed (apk add php7-apcu)
+// and enabled apc.rfc1867 option.
+// By default refresh time is set to 1 second. You can set this value to true
+// or any integer value indicating number of seconds.
+//$config['upload_progress'] = false;
+
+
+// ----------------------------------
+// USER PREFERENCES
+// ----------------------------------
+
+// Use this charset as fallback for message decoding
+$config['default_charset'] = 'UTF-8';
+
+// display remote inline images
+// 0 - Never, always ask
+// 1 - Ask if sender is not in address book
+// 2 - Always show inline images
+//$config['show_images'] = 0;
+
+// save compose message every 300 seconds (5min)
+//$config['draft_autosave'] = 300;
+
+// When replying:
+// -1 - don't cite the original message
+// 0 - place cursor below the original message
+// 1 - place cursor above original message (top posting)
+//$config['reply_mode'] = 0;