aboutsummaryrefslogtreecommitdiffstats
path: root/community/rspamd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-15 13:23:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-15 13:24:35 +0000
commit73bb8f0ae399f168880eedef0d38168c8eb7d5d4 (patch)
tree2670d0af1ab63c86a20a23f3308152e85dd3fcfc /community/rspamd
parentc96ade24bf43dff6e34a2351c6f0d18070a6807a (diff)
downloadaports-73bb8f0ae399f168880eedef0d38168c8eb7d5d4.tar.bz2
aports-73bb8f0ae399f168880eedef0d38168c8eb7d5d4.tar.xz
community/rspamd: build fix for non-x86
Diffstat (limited to 'community/rspamd')
-rw-r--r--community/rspamd/APKBUILD2
-rw-r--r--community/rspamd/fix-build-on-non-x86-platforms.patch30
2 files changed, 32 insertions, 0 deletions
diff --git a/community/rspamd/APKBUILD b/community/rspamd/APKBUILD
index e2c5819c67..0c3841bf2b 100644
--- a/community/rspamd/APKBUILD
+++ b/community/rspamd/APKBUILD
@@ -25,6 +25,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vstakhov/$pkgname/archive/$p
$pkgname.initd
$pkgname.confd
cmakelists.patch
+ fix-build-on-non-x86-platforms.patch
worker.conf.in
"
@@ -150,4 +151,5 @@ sha512sums="625f7bffe75e81866f5eefabab4fb41bddb823397f6a930ab4c452e2219b4a33a5c4
df37726d03e676b16d707854d95bafc9162da65c27bb150edbfc0cb00f1842188a1f2a8f1b82be5ae2a253b4f4db4d93dfe804a89feb988b5af858eb3f3458be rspamd.initd
e417dd825d1b4d03d115db037b2fdf2f48a35420ee7a9010d97167b6c31e88d6c0a15dd33b21d7d76856db0fdc5097c922fcdf1d8164d1e92ae377f7c5303947 rspamd.confd
fa0e14d507cd7421a20916506c03e6e6c95fb2f38736e69540ee3e066da883c2ee4cb779ee8787756e4a1831ff8f04150ce592d4d6df08d8a18d55f3c6de4646 cmakelists.patch
+c9b8551a8ea39656b573c137722a5eb72dbf108e289eb952e0014eb2fd92603e84cc7302caf1c15a40e1d2cdd668e92508515797404e740b8d890afb9985c120 fix-build-on-non-x86-platforms.patch
2169a8c4b4af6df9f3bbf4addeac564c9485a9d6a30fd15cf167093488362791c003a0d03360049c43d827e7fa767c1ad3522de6699b0247b75aa049c0b51214 worker.conf.in"
diff --git a/community/rspamd/fix-build-on-non-x86-platforms.patch b/community/rspamd/fix-build-on-non-x86-platforms.patch
new file mode 100644
index 0000000000..737473272b
--- /dev/null
+++ b/community/rspamd/fix-build-on-non-x86-platforms.patch
@@ -0,0 +1,30 @@
+From b563e16adb19086f99f9ecf6b3c3636f44229758 Mon Sep 17 00:00:00 2001
+From: Vsevolod Stakhov <vsevolod@highsecure.ru>
+Date: Tue, 8 May 2018 20:44:10 +0100
+Subject: [PATCH] [Fix] Fix build on non-x86 platforms
+
+Issue: #2226
+---
+ contrib/t1ha/t1ha.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/contrib/t1ha/t1ha.h b/contrib/t1ha/t1ha.h
+index 30c408c87..191758c57 100644
+--- a/contrib/t1ha/t1ha.h
++++ b/contrib/t1ha/t1ha.h
+@@ -217,13 +217,13 @@
+ #define T1HA_API
+ #endif /* T1HA_API */
+
+-#if defined(_MSC_VER) && defined(__ia32__)
++#if defined(_MSC_VER)
+ #define T1HA_ALIGN_PREFIX __declspec(align(32)) /* required only for SIMD */
+ #else
+ #define T1HA_ALIGN_PREFIX
+ #endif /* _MSC_VER */
+
+-#if defined(__GNUC__) && defined(__ia32__)
++#if defined(__GNUC__)
+ #define T1HA_ALIGN_SUFFIX \
+ __attribute__((aligned(32))) /* required only for SIMD */
+ #else