aboutsummaryrefslogtreecommitdiffstats
path: root/community/rt4
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-06 18:04:18 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-09-07 08:30:45 +0000
commit2e8993d237eda91f8465465a9119f76631a9d905 (patch)
tree1e4064f6e7122ecfb7961cf5aaaba6defa4de9a5 /community/rt4
parentb882ba04ea9c019f215b3cede5a4d4167aa3eded (diff)
downloadaports-2e8993d237eda91f8465465a9119f76631a9d905.tar.bz2
aports-2e8993d237eda91f8465465a9119f76631a9d905.tar.xz
community/rt4: upgrade to 4.4.2
Diffstat (limited to 'community/rt4')
-rw-r--r--community/rt4/0001-email-allow-envelope-from-overriding-from-templates.patch26
-rw-r--r--community/rt4/APKBUILD35
-rw-r--r--community/rt4/rt-varpath.patch4
3 files changed, 29 insertions, 36 deletions
diff --git a/community/rt4/0001-email-allow-envelope-from-overriding-from-templates.patch b/community/rt4/0001-email-allow-envelope-from-overriding-from-templates.patch
index d82d58ab50..581b615dc6 100644
--- a/community/rt4/0001-email-allow-envelope-from-overriding-from-templates.patch
+++ b/community/rt4/0001-email-allow-envelope-from-overriding-from-templates.patch
@@ -5,9 +5,19 @@ Add X-RT-Envelope-From header that will override the envelope
from if using sendmailpipe mail sending.
diff -ru rt-4.2.9.orig/lib/RT/Interface/Email.pm rt-4.2.9/lib/RT/Interface/Email.pm
---- rt-4.2.9.orig/lib/RT/Interface/Email.pm 2014-10-23 18:49:38.000000000 -0300
-+++ rt-4.2.9/lib/RT/Interface/Email.pm 2014-10-31 08:14:48.557121324 -0200
-@@ -370,6 +370,9 @@
+--- rt-4.2.9.orig/lib/RT/Interface/Email.pm 2014-10-23 18:49:38.000000000 -0300
++++ rt-4.2.9/lib/RT/Interface/Email.pm 2014-10-31 08:14:48.557121324 -0200
+@@ -754,7 +754,8 @@
+ if ($QueueAddressOverride) {
+ $OutgoingMailAddress = $QueueAddressOverride;
+ } else {
+- $OutgoingMailAddress ||= $Queue->CorrespondAddress
++ $OutgoingMailAddress ||= $envelope_from
++ || $Queue->CorrespondAddress
+ || RT->Config->Get('CorrespondAddress');
+ }
+ }
+@@ -824,6 +825,9 @@
my $msgid = Encode::decode( "UTF-8", $args{'Entity'}->head->get('Message-ID') || '' );
chomp $msgid;
@@ -17,13 +27,3 @@ diff -ru rt-4.2.9.orig/lib/RT/Interface/Email.pm rt-4.2.9/lib/RT/Interface/Email
# If we don't have any recipients to send to, don't send a message;
unless ( $args{'Entity'}->head->get('To')
|| $args{'Entity'}->head->get('Cc')
-@@ -447,7 +450,8 @@
- if ($QueueAddressOverride) {
- $OutgoingMailAddress = $QueueAddressOverride;
- } else {
-- $OutgoingMailAddress ||= $Queue->CorrespondAddress
-+ $OutgoingMailAddress ||= $envelope_from
-+ || $Queue->CorrespondAddress
- || RT->Config->Get('CorrespondAddress');
- }
- }
diff --git a/community/rt4/APKBUILD b/community/rt4/APKBUILD
index 69226223f7..d7111adf63 100644
--- a/community/rt4/APKBUILD
+++ b/community/rt4/APKBUILD
@@ -2,12 +2,12 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rt4
-pkgver=4.4.1
-pkgrel=1
+pkgver=4.4.2
+pkgrel=0
pkgdesc="Request Tracker - issue and bug tracker"
pkgusers="rt4"
pkggroups="rt4"
-url="http://www.bestpractical.com/rt"
+url="https://bestpractical.squarespace.com/request-tracker"
arch="noarch"
license="GPLv2+"
depends="perl
@@ -112,10 +112,10 @@ source="https://download.bestpractical.com/pub/rt/release/rt-$pkgver.tar.gz
builddir="$srcdir"/rt-$pkgver
prepare() {
- default_prepare || return 1 # apply patches
+ default_prepare
sed -i -e 's_$RT::BasePath/share/fonts/_/usr/share/fonts/TTF/_g' \
- "$builddir"/etc/RT_Config.pm* || return 1
+ "$builddir"/etc/RT_Config.pm*
cat <<-'EOF' >> config.layout
# Alpine directory layout.
@@ -150,7 +150,8 @@ prepare() {
build() {
cd "$builddir"
- autoconf && ./configure \
+ autoconf
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--enable-layout=Alpine \
@@ -158,30 +159,22 @@ build() {
--with-web-group=rt4 \
--with-web-user=rt4 \
--disable-gpg \
- --disable-graphviz \
- || return 1
- make testdeps && make || return 1
+ --disable-graphviz
+ make testdeps
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
# delete the droid fonts as we get them from ttf-droid
rm -rf "$pkgdir"/usr/share/rt4/fonts/ \
"$pkgdir"/usr/local
}
-md5sums="3587522b92a02d3866e07dc9361ca1e2 rt-4.4.1.tar.gz
-f05ff9fc3a6888e5b3f937697fbfd00f 0001-email-allow-envelope-from-overriding-from-templates.patch
-9c1cd44a5e177a73cf92f6790fe5cd78 rt-varpath.patch
-344258a3e066d23fb684b3013eb70cd0 rt-autoconf-version.patch"
-sha256sums="f87329911020e01b39948070aec2bd7abf0c81641f0cf2f25e01c690a19f24f5 rt-4.4.1.tar.gz
-02db996b6f1b62b50364231b8ca4733bd95817c2a5c340b0934ba9f052ffbb50 0001-email-allow-envelope-from-overriding-from-templates.patch
-0d1905e29346d1a2a8e8bd5de7931721de872bccfdbb26421f3b6c00e39ca895 rt-varpath.patch
-8d7d8398af6a20f847e52408a2fb4b9ab15788cc84cd628fa65e11067df67250 rt-autoconf-version.patch"
-sha512sums="2cb797e013b14201ececec2c408257fe3a998fefdafd0944efda0236caac40be4cc45878cbda7bf9ae82b3757de6167263db2b90331d925db1f916a8420adf94 rt-4.4.1.tar.gz
-eb850824299e40a98b547a41eb83efc4edd8e7a79a9704f6bd010f97261d0068dfdb7c435c294eba6fb244c8275d3fe076c173672e6ae329e5a8cb6337ccc782 0001-email-allow-envelope-from-overriding-from-templates.patch
-8a96b5482d649e373600e0b0e04abe382f61b0ed3ec463625163182fd71569c61c236e2cf48abd496f0d747b11b604acd1f958d8d891a2333bfde7450fb995d3 rt-varpath.patch
+sha512sums="23e318d10c49d39c1542664efa2b9f98d1dcd613c279dc8ceca0ad9aed89a5d989316e833492ed3281543ec85f6e0f5141a86f70852776bf0d54166aa126431e rt-4.4.2.tar.gz
+010bcdaab295086e69ecbf066becd718d9c33507cc9685bdb2a8c251d21bbfbc0f5b21b476d38df1b06a093678d550c1542c775dd6fc61295ea267a419a9867e 0001-email-allow-envelope-from-overriding-from-templates.patch
+62308220d00e11059491533e87fb7378226609fcef332c31b2db75ba32bbbf3343cd0eb7fd53288f62700ee456669f216bd78550fb1cd7e5d4fe85ef41976c0c rt-varpath.patch
cac79f231e1b1915962de8e4a86812fcaa0f1f64384a34557fac860c0fb0ae33d5dfd2371c30c07310391735e7348022e62bd5d453674a41ac7e77865d79dab9 rt-autoconf-version.patch"
diff --git a/community/rt4/rt-varpath.patch b/community/rt4/rt-varpath.patch
index 50ce551568..6834a2551d 100644
--- a/community/rt4/rt-varpath.patch
+++ b/community/rt4/rt-varpath.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -357,7 +357,7 @@
+@@ -379,7 +379,7 @@
AC_SUBST([CONFIG_FILE_PATH], ${exp_sysconfdir})
AC_SUBST([RT_BIN_PATH], ${exp_bindir})
AC_SUBST([RT_SBIN_PATH], ${exp_sbindir})
@@ -9,7 +9,7 @@
AC_SUBST([RT_MAN_PATH], ${exp_mandir})
AC_SUBST([RT_FONT_PATH], ${exp_fontdir})
AC_SUBST([RT_PLUGIN_PATH], ${exp_plugindir})
-@@ -409,7 +409,7 @@
+@@ -431,7 +431,7 @@
AC_SUBST([CONFIG_FILE_PATH_R], ${exp_sysconfdir})
AC_SUBST([RT_BIN_PATH_R], ${exp_bindir})
AC_SUBST([RT_SBIN_PATH_R], ${exp_sbindir})