aboutsummaryrefslogtreecommitdiffstats
path: root/community/rt4
diff options
context:
space:
mode:
authorKory Prince <korylprince@gmail.com>2018-03-26 09:41:05 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-04-02 14:20:13 +0000
commit73ef5a9de125f163b35dd55854dd69521bf5a4c5 (patch)
tree4226225acb20e6b97ecee3e39ff6cae2cd3bfe00 /community/rt4
parent9f80be0770ff7f3e644916d66abc1175d0265349 (diff)
downloadaports-73ef5a9de125f163b35dd55854dd69521bf5a4c5.tar.bz2
aports-73ef5a9de125f163b35dd55854dd69521bf5a4c5.tar.xz
community/rt4: fix perl warning messages
Fix #8739 by cherry-picking upstream 971daa20c This patch should be removed on the next rt4 release This patch should be applied after issue #8738 patch.
Diffstat (limited to 'community/rt4')
-rw-r--r--community/rt4/0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch25
-rw-r--r--community/rt4/APKBUILD2
2 files changed, 27 insertions, 0 deletions
diff --git a/community/rt4/0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch b/community/rt4/0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch
new file mode 100644
index 0000000000..27756f82c0
--- /dev/null
+++ b/community/rt4/0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch
@@ -0,0 +1,25 @@
+From c50856a0807b118e27af890b1c53b93c81158459 Mon Sep 17 00:00:00 2001
+From: Dominic Hargreaves <dom@earth.li>
+Date: Mon, 19 Jun 2017 19:29:42 +0100
+Subject: [PATCH] Fix "Unescaped left brace in regex" warning in perl 5.26
+
+---
+ share/html/Search/Elements/EditSort | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/share/html/Search/Elements/EditSort b/share/html/Search/Elements/EditSort
+index 4ab08002f..4853e17f2 100644
+--- a/share/html/Search/Elements/EditSort
++++ b/share/html/Search/Elements/EditSort
+@@ -119,7 +119,7 @@ $fields{$_} = $_ for @cfs;
+ # Add all available CustomRoles to the list of sortable columns.
+ my @roles = grep /^CustomRole/, @{$ARGS{AvailableColumns}};
+ for my $role (@roles) {
+- my ($label) = $role =~ /^CustomRole.{(.*)}$/;
++ my ($label) = $role =~ /^CustomRole.\{(.*)\}$/;
+ my $value = $role;
+ $fields{$label . '.EmailAddress' } = $value . '.EmailAddress';
+ }
+--
+2.15.1
+
diff --git a/community/rt4/APKBUILD b/community/rt4/APKBUILD
index 661cac47b2..36b2bfd43c 100644
--- a/community/rt4/APKBUILD
+++ b/community/rt4/APKBUILD
@@ -106,6 +106,7 @@ makedepends="autoconf"
install="$pkgname.pre-install $pkgname.pre-upgrade"
source="https://download.bestpractical.com/pub/rt/release/rt-$pkgver.tar.gz
0001-email-allow-envelope-from-overriding-from-templates.patch
+ 0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch
rt-varpath.patch
rt-autoconf-version.patch
"
@@ -176,5 +177,6 @@ package() {
sha512sums="23e318d10c49d39c1542664efa2b9f98d1dcd613c279dc8ceca0ad9aed89a5d989316e833492ed3281543ec85f6e0f5141a86f70852776bf0d54166aa126431e rt-4.4.2.tar.gz
b88f6a6c42510c6e95f4d206b93d5dcea001622619edc212018edd7f36c20a24acf812acf8f09dcb3413fcb1733b53ce3072c2097cdc18812e3a978ea04218d0 0001-email-allow-envelope-from-overriding-from-templates.patch
+c5c678bfea612fda984107ea62dc9371c33864f1a28fad4239671ee807c89911ca7f74f5c56076932abb1ea4bebccfabb3731d6082048f255eaa3e2558b0ac92 0001-Fix-Unescaped-left-brace-in-regex-warning-in-perl-5.patch
62308220d00e11059491533e87fb7378226609fcef332c31b2db75ba32bbbf3343cd0eb7fd53288f62700ee456669f216bd78550fb1cd7e5d4fe85ef41976c0c rt-varpath.patch
cac79f231e1b1915962de8e4a86812fcaa0f1f64384a34557fac860c0fb0ae33d5dfd2371c30c07310391735e7348022e62bd5d453674a41ac7e77865d79dab9 rt-autoconf-version.patch"