aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-mathematical
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-24 23:35:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-24 23:36:42 +0200
commit01678c4cee901257f4dc4e8831851b227f8ef6af (patch)
tree67c12695bc98f465f21d217d6218f28a7b392400 /community/ruby-mathematical
parentd463d99d3e4f8b850495ac5e429a98924098ee1d (diff)
downloadaports-01678c4cee901257f4dc4e8831851b227f8ef6af.tar.bz2
aports-01678c4cee901257f4dc4e8831851b227f8ef6af.tar.xz
community/ruby-mathematical: upgrade to 1.6.9
Diffstat (limited to 'community/ruby-mathematical')
-rw-r--r--community/ruby-mathematical/APKBUILD14
-rw-r--r--community/ruby-mathematical/fix-extconf.patch60
-rw-r--r--community/ruby-mathematical/use-system-mtex2mml.patch59
3 files changed, 4 insertions, 129 deletions
diff --git a/community/ruby-mathematical/APKBUILD b/community/ruby-mathematical/APKBUILD
index ea954b0fdb..9cf0c69f2a 100644
--- a/community/ruby-mathematical/APKBUILD
+++ b/community/ruby-mathematical/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-mathematical
_gemname=${pkgname#ruby-}
-pkgver=1.6.8
+pkgver=1.6.9
pkgrel=0
pkgdesc="Convert mathematical equations to SVGs, PNGs, or MathML"
url="https://www.gjtorikian.com/mathematical/"
@@ -13,10 +13,7 @@ makedepends="cmake lasem-dev mtex2mml-dev ruby-dev"
checkdepends="mtex2mml-fixtures ruby-io-console ruby-irb ruby-minitest
ruby-nokogiri ruby-rake"
source="$pkgname-$pkgver.tar.gz::https://github.com/gjtorikian/$_gemname/archive/v$pkgver.tar.gz
- use-system-mtex2mml.patch
- fix-extconf.patch
- use-system-mtex2mml-fixtures.patch
- disable-test-assert-failing-on-32bit.patch"
+ use-system-mtex2mml-fixtures.patch"
builddir="$srcdir/$_gemname-$pkgver"
prepare() {
@@ -73,8 +70,5 @@ package() {
rm -r ext/ test/ Rakefile *.md *.txt || true
}
-sha512sums="d724882253abf5262aeba67ad00496bd1f477b5347e5b8afb75d57c00916f705345cd18834ee238b7c0e64515a2263ae615a365c97e67053f641bc0a8acb7794 ruby-mathematical-1.6.8.tar.gz
-3a5cd16d26db53415c5d047a4ddec398872bdead1eb60f65629f5680487de9d6a1d1ffad528a1a97da47aabd4696bdee06da9792e0b0d0fed95c4fae7af96492 use-system-mtex2mml.patch
-47ca73d585f322e98b580544c812f7d7d71f43cba21784a80438fb250952b156d18254ca4a885828e8d76f8b897165f23ef74772ff2e54d12edc58b10c8bcb99 fix-extconf.patch
-35c691b2006e6c0bac26ebb0adac5ffa99fbc37100c94d5978508b91b3df84544e4fc8fa38b5de01ae0fcc644c1eeb97b6129f59b4488b467c1ded468277c400 use-system-mtex2mml-fixtures.patch
-7d94779a665a4e055d2aed822568f5de9581af85e96cbb218b139627eaa103bb5338f61738cf3b4e82dcbfc4ad857f8ea80564655543176431b8b0ea8c7ccb93 disable-test-assert-failing-on-32bit.patch"
+sha512sums="0bd5ba695ea2506a1b6f29ec1c80b7572e9f73c00500f4f4d81e70430dd48f1a63c488067ed6db251130e2242cb667e3baabece47ecf4a6bb8d52d0b856cdce1 ruby-mathematical-1.6.9.tar.gz
+35c691b2006e6c0bac26ebb0adac5ffa99fbc37100c94d5978508b91b3df84544e4fc8fa38b5de01ae0fcc644c1eeb97b6129f59b4488b467c1ded468277c400 use-system-mtex2mml-fixtures.patch"
diff --git a/community/ruby-mathematical/fix-extconf.patch b/community/ruby-mathematical/fix-extconf.patch
deleted file mode 100644
index a73b39989b..0000000000
--- a/community/ruby-mathematical/fix-extconf.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 7ff0cd468ae877eb3de3bff0931b768560849d6f Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Sat, 25 Mar 2017 01:14:41 +0100
-Subject: [PATCH] Do not add -llasem and -lmtex2MML to $LIBS when pkg_config is used
-
-pkg-config provides correct arguments to the linker.
-
-It seems that the lasem library is named differently on various
-systems. Unmodified lasem 0.5.0 installs library named
-liblasm-0.6.so.5.0.0 (and symlink liblasm.so), so linker fails when
- -llasm is passed.
-
-Upstream-Issue: https://github.com/gjtorikian/mathematical/pull/71
----
- ext/mathematical/extconf.rb | 17 ++++++++++++++---
- 1 file changed, 14 insertions(+), 3 deletions(-)
-
-diff --git a/ext/mathematical/extconf.rb b/ext/mathematical/extconf.rb
-index 04993aa..b6cf5bf 100644
---- a/ext/mathematical/extconf.rb
-+++ b/ext/mathematical/extconf.rb
-@@ -69,8 +69,14 @@ if !using_system_mtex2mml?
- end
- FileUtils.mkdir_p(MTEX2MML_LIB_DIR)
- FileUtils.cp_r(File.join(MTEX2MML_BUILD_DIR, 'libmtex2MML.a'), MTEX2MML_LIB_DIR)
-+ $LIBS << ' -lmtex2MML'
- else
-- dir_config('mtex2MML').any? || pkg_config('libmtex2MML') || system('dpkg -s libmtex2MML >/dev/null')
-+ if dir_config('mtex2MML').any? || system('dpkg -s libmtex2MML >/dev/null')
-+ $LIBS << ' -lmtex2MML'
-+ else
-+ # NOTE: pkg_config implicitly adds right -l argument for the linker.
-+ pkg_config('libmtex2MML') || pkg_config('mtex2MML')
-+ end
- end
-
- if !using_system_lasem?
-@@ -82,8 +88,14 @@ if !using_system_lasem?
- end
- FileUtils.mkdir_p(LASEM_LIB_DIR)
- FileUtils.cp_r(File.join(LASEM_BUILD_DIR, "liblasem.#{SHARED_EXT}"), LASEM_LIB_DIR)
-+ $LIBS << '-llasem'
- else
-- dir_config('lasem').any? || pkg_config('liblasem') || system('dpkg -s liblasem >/dev/null')
-+ if dir_config('lasem').any? || system('dpkg -s liblasem >/dev/null')
-+ $LIBS << '-llasem'
-+ else
-+ # NOTE: pkg_config implicitly adds right -l argument for the linker.
-+ pkg_config('liblasem') || pkg_config('lasem')
-+ end
- end
-
- LIB_DIRS = [MTEX2MML_LIB_DIR, LASEM_LIB_DIR]
-@@ -96,6 +108,5 @@ find_header('mtex2MML.h', MTEX2MML_SRC_DIR)
- flag = ENV['TRAVIS'] ? '-O0' : '-O2'
- $LDFLAGS << " #{`pkg-config --static --libs glib-2.0 gdk-pixbuf-2.0 cairo pango`.chomp}"
- $CFLAGS << " #{flag} #{`pkg-config --cflags glib-2.0 gdk-pixbuf-2.0 cairo pango`.chomp}"
--$LIBS << ' -lmtex2MML -llasem'
-
- create_makefile('mathematical/mathematical')
diff --git a/community/ruby-mathematical/use-system-mtex2mml.patch b/community/ruby-mathematical/use-system-mtex2mml.patch
deleted file mode 100644
index 8cfbf99aad..0000000000
--- a/community/ruby-mathematical/use-system-mtex2mml.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 9810816577a18e844fd21eb0f7fa73b1e5e71b8a Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Sat, 25 Mar 2017 01:10:36 +0100
-Subject: [PATCH] Allow to compile against system-provided mtex2MML
-
-I'm writing package for Alpine Linux and want to compile mathematical
-against system-provided mtex2MML instead of bundled one.
-
-Upstream-Issue: https://github.com/gjtorikian/mathematical/pull/71
----
- ext/mathematical/extconf.rb | 21 ++++++++++++++-------
- 1 file changed, 14 insertions(+), 7 deletions(-)
-
-diff --git a/ext/mathematical/extconf.rb b/ext/mathematical/extconf.rb
-index eb6a8d8..04993aa 100644
---- a/ext/mathematical/extconf.rb
-+++ b/ext/mathematical/extconf.rb
-@@ -21,6 +21,10 @@ def using_system_lasem?
- arg_config('--use-system-lasem', !!ENV['MATHEMATICAL_USE_SYSTEM_LASEM'])
- end
-
-+def using_system_mtex2mml?
-+ arg_config('--use-system-mtex2MML', !!ENV['MATHEMATICAL_USE_SYSTEM_MTEX2MML'])
-+end
-+
- ROOT_TMP = File.expand_path(File.join(File.dirname(__FILE__), '..', '..', 'tmp'))
-
- LASEM_DIR = File.expand_path(File.join(File.dirname(__FILE__), 'lasem'))
-@@ -57,10 +61,16 @@ end
- clean_dir(MTEX2MML_BUILD_DIR)
- clean_dir(LASEM_BUILD_DIR)
-
--# build mtex2MML library
--Dir.chdir(MTEX2MML_BUILD_DIR) do
-- system 'cmake ..'
-- system 'make libmtex2MML_static'
-+if !using_system_mtex2mml?
-+ # build mtex2MML library
-+ Dir.chdir(MTEX2MML_BUILD_DIR) do
-+ system 'cmake ..'
-+ system 'make libmtex2MML_static'
-+ end
-+ FileUtils.mkdir_p(MTEX2MML_LIB_DIR)
-+ FileUtils.cp_r(File.join(MTEX2MML_BUILD_DIR, 'libmtex2MML.a'), MTEX2MML_LIB_DIR)
-+else
-+ dir_config('mtex2MML').any? || pkg_config('libmtex2MML') || system('dpkg -s libmtex2MML >/dev/null')
- end
-
- if !using_system_lasem?
-@@ -76,9 +86,6 @@ else
- dir_config('lasem').any? || pkg_config('liblasem') || system('dpkg -s liblasem >/dev/null')
- end
-
--FileUtils.mkdir_p(MTEX2MML_LIB_DIR)
--FileUtils.cp_r(File.join(MTEX2MML_BUILD_DIR, 'libmtex2MML.a'), MTEX2MML_LIB_DIR)
--
- LIB_DIRS = [MTEX2MML_LIB_DIR, LASEM_LIB_DIR]
- HEADER_DIRS = [MTEX2MML_SRC_DIR, LASEM_SRC_DIR]
-