aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-mathematical
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-29 00:55:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-29 00:55:55 +0200
commit6570c71ff30fbb10be78f8edf13c32ce560ffd2e (patch)
treebb2adbe8b3bd649cd9eca8248e1c5648a9518e06 /community/ruby-mathematical
parentfdcff37daafb24149348e4b531117d15c48ca3ec (diff)
downloadaports-6570c71ff30fbb10be78f8edf13c32ce560ffd2e.tar.bz2
aports-6570c71ff30fbb10be78f8edf13c32ce560ffd2e.tar.xz
community/ruby-mathematical: upgrade to 1.6.8
Diffstat (limited to 'community/ruby-mathematical')
-rw-r--r--community/ruby-mathematical/APKBUILD16
-rw-r--r--community/ruby-mathematical/disable-unstable-delimiter-test.patch13
2 files changed, 9 insertions, 20 deletions
diff --git a/community/ruby-mathematical/APKBUILD b/community/ruby-mathematical/APKBUILD
index 9ce9184bf0..ea954b0fdb 100644
--- a/community/ruby-mathematical/APKBUILD
+++ b/community/ruby-mathematical/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-mathematical
_gemname=${pkgname#ruby-}
-pkgver=1.6.0
-pkgrel=1
+pkgver=1.6.8
+pkgrel=0
pkgdesc="Convert mathematical equations to SVGs, PNGs, or MathML"
url="https://www.gjtorikian.com/mathematical/"
arch="all"
@@ -16,8 +16,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/gjtorikian/$_gemname/archive
use-system-mtex2mml.patch
fix-extconf.patch
use-system-mtex2mml-fixtures.patch
- disable-test-assert-failing-on-32bit.patch
- disable-unstable-delimiter-test.patch"
+ disable-test-assert-failing-on-32bit.patch"
builddir="$srcdir/$_gemname-$pkgver"
prepare() {
@@ -25,6 +24,10 @@ prepare() {
# Don't load bundler, it messes with GEM_PATH.
sed -i "/^require\s*[\"']bundler\/setup/d" test/test_helper.rb
+
+ # Some tests in this file are unstable (randomly fails).
+ # https://github.com/gjtorikian/mathematical/issues/73
+ rm test/mathematical/delimiters_test.rb
}
build() {
@@ -70,9 +73,8 @@ package() {
rm -r ext/ test/ Rakefile *.md *.txt || true
}
-sha512sums="3af398f5fe30b0feec52ddf1b0bcc06185a66aac115995e3d8ccf3c452c93786a482e55eb4bdb1823a8627753ba61a86e7f50bf4d3a125ab7c7055f7a36a708b ruby-mathematical-1.6.0.tar.gz
+sha512sums="d724882253abf5262aeba67ad00496bd1f477b5347e5b8afb75d57c00916f705345cd18834ee238b7c0e64515a2263ae615a365c97e67053f641bc0a8acb7794 ruby-mathematical-1.6.8.tar.gz
3a5cd16d26db53415c5d047a4ddec398872bdead1eb60f65629f5680487de9d6a1d1ffad528a1a97da47aabd4696bdee06da9792e0b0d0fed95c4fae7af96492 use-system-mtex2mml.patch
47ca73d585f322e98b580544c812f7d7d71f43cba21784a80438fb250952b156d18254ca4a885828e8d76f8b897165f23ef74772ff2e54d12edc58b10c8bcb99 fix-extconf.patch
35c691b2006e6c0bac26ebb0adac5ffa99fbc37100c94d5978508b91b3df84544e4fc8fa38b5de01ae0fcc644c1eeb97b6129f59b4488b467c1ded468277c400 use-system-mtex2mml-fixtures.patch
-7d94779a665a4e055d2aed822568f5de9581af85e96cbb218b139627eaa103bb5338f61738cf3b4e82dcbfc4ad857f8ea80564655543176431b8b0ea8c7ccb93 disable-test-assert-failing-on-32bit.patch
-396708b20db0c91df9434b548796b97fb707f6eed612226e73557830572e73bc0b2932ffbe809b83e09de434420189bdb825f5ef742897eaf2ad92ba5024e204 disable-unstable-delimiter-test.patch"
+7d94779a665a4e055d2aed822568f5de9581af85e96cbb218b139627eaa103bb5338f61738cf3b4e82dcbfc4ad857f8ea80564655543176431b8b0ea8c7ccb93 disable-test-assert-failing-on-32bit.patch"
diff --git a/community/ruby-mathematical/disable-unstable-delimiter-test.patch b/community/ruby-mathematical/disable-unstable-delimiter-test.patch
deleted file mode 100644
index 83e6ff948f..0000000000
--- a/community/ruby-mathematical/disable-unstable-delimiter-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Disable unstable delimiter test
-
-Upstream-Issue: https://github.com/gjtorikian/mathematical/issues/73
---- a/test/mathematical/delimiters_test.rb
-+++ b/test/mathematical/delimiters_test.rb
-@@ -46,6 +46,7 @@
- end
-
- def test_mixed
-+ skip 'Disabled, because it randomly fails (#73)'
- render = Mathematical.new(:delimiter => [:brackets, :double], :format => :mathml)
-
- fixture_tex = "\\[\\alpha\\] $$\\beta$$"