aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rspec-expectations
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
commit3297d634f4371b930eba14293bc829b9c4a5150e (patch)
tree2198f7bd88fa2d064f4a92746f7f46fdd065fb03 /community/ruby-rspec-expectations
parent94f91d25906569a622b1bdbd61766449230daa27 (diff)
downloadaports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.bz2
aports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.xz
community/ruby-rspec*: move from testing
Diffstat (limited to 'community/ruby-rspec-expectations')
-rw-r--r--community/ruby-rspec-expectations/APKBUILD40
-rw-r--r--community/ruby-rspec-expectations/gemspec.patch12
2 files changed, 52 insertions, 0 deletions
diff --git a/community/ruby-rspec-expectations/APKBUILD b/community/ruby-rspec-expectations/APKBUILD
new file mode 100644
index 0000000000..b46c04ab8d
--- /dev/null
+++ b/community/ruby-rspec-expectations/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-expectations
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="Provides a readable API to express expected outcomes of a code example in RSpec"
+url="https://relishapp.com/rspec/rspec-expectations/"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-diff-lcs ruby-rspec-support>=${pkgver%.*}.0"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a ruby-rspec-expectations-3.7.0.tar.gz
+1d477004521852e23d01b197187dbb434a2c7fd179e506c82a12e17f5d52470fe2a113112e7052b9479077eafa6759beb07c03301de1f8ea7f5c4643c92d8346 gemspec.patch"
diff --git a/community/ruby-rspec-expectations/gemspec.patch b/community/ruby-rspec-expectations/gemspec.patch
new file mode 100644
index 0000000000..644aad1ada
--- /dev/null
+++ b/community/ruby-rspec-expectations/gemspec.patch
@@ -0,0 +1,12 @@
+--- a/rspec-expectations.gemspec
++++ b/rspec-expectations.gemspec
+@@ -13,8 +13,7 @@
+ s.summary = "rspec-expectations-#{RSpec::Expectations::Version::STRING}"
+ s.description = "rspec-expectations provides a simple, readable API to express expected outcomes of a code example."
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += %w[README.md LICENSE.md Changelog.md .yardopts .document]
++ s.files = Dir["lib/**/*"]
+ s.test_files = []
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"