aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-20 14:40:12 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-20 16:46:01 +0200
commit42fb798cb5dd5bc2cea1278a7fc0e49bffbba8a3 (patch)
tree5a2330cd26dacf3dd1cd2d9fb5947a5aca475be4 /community/rust
parent207941559ddce18b7b0cfeb09b7fab673233c4da (diff)
downloadaports-42fb798cb5dd5bc2cea1278a7fc0e49bffbba8a3.tar.bz2
aports-42fb798cb5dd5bc2cea1278a7fc0e49bffbba8a3.tar.xz
community/rust: use `x.py install` instead of `x.py dist`
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 15a5576b8e..c6a2352bb4 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -115,12 +115,8 @@ package() {
RUST_BACKTRACE=1 \
RUSTC_CRT_STATIC="false" \
- ./x.py dist -v
-
- local component; for component in rustc rust-std; do
- tar -xf "build/dist/$component-$pkgver-$CTARGET.tar.gz"
- ./"$component-$pkgver-$CTARGET"/install.sh --destdir="$pkgdir" --prefix=/usr --disable-ldconfig
- done
+ DESTDIR="$pkgdir" \
+ ./x.py install -v
cd "$pkgdir"