aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-21 00:13:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-21 00:08:30 +0200
commit69cf09dbbcd3936f64a3f8ed45e89dcf69fb1090 (patch)
tree8a03fe2233e55719a8ce72d6c84bf386a243e15c /community/rust
parentb00a8dd49f28fc43d56f2dabca34432ef5187c20 (diff)
downloadaports-69cf09dbbcd3936f64a3f8ed45e89dcf69fb1090.tar.bz2
aports-69cf09dbbcd3936f64a3f8ed45e89dcf69fb1090.tar.xz
community/rust: fix check error
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 06a8e408dc..9af9007825 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -128,6 +128,12 @@ build() {
check() {
cd "$builddir"
+ # At this moment lib/rustlib/$CTARGET/lib does not contain a complete
+ # copy of the .so libs from lib (they will be copied there during
+ # `x.py install`). Thus we must set LD_LIBRARY_PATH for tests to work.
+ # This is related to change-rpath-to-rustlib.patch.
+ export LD_LIBRARY_PATH="$builddir/build/$CTARGET/stage2/lib"
+
"$srcdir"/check-rustc "$builddir"/build/$CTARGET/stage2/bin/rustc
# XXX: There's some problem with these tests, we will figure it out later.
@@ -138,6 +144,8 @@ check() {
msg "Running tests for cargo..."
CFG_DISABLE_CROSS_TESTS=1 ./x.py test --no-fail-fast src/tools/cargo
+
+ unset LD_LIBRARY_PATH
}
package() {