aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-01-05 23:52:13 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-01-06 00:52:21 +0100
commit828622384ec41ab33ea6c431d0089a9d606a9ae1 (patch)
treee55a315ee64ad25310482e668968274b6cfc0d0a /community/rust
parent7b725b28fc02b6131ab2807ec22bc9ce3f286cc2 (diff)
downloadaports-828622384ec41ab33ea6c431d0089a9d606a9ae1.tar.bz2
aports-828622384ec41ab33ea6c431d0089a9d606a9ae1.tar.xz
community/rust: upgrade to 1.23.0
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD8
-rw-r--r--community/rust/alpine-target.patch6
2 files changed, 8 insertions, 6 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 6c4f8717f5..42497a136e 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -3,9 +3,9 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=rust
-pkgver=1.22.1
+pkgver=1.23.0
_llvmver=4
-_bootver=1.21.1
+_bootver=1.22.0
pkgrel=0
pkgdesc="The Rust Programming Language (compiler)"
url="http://www.rust-lang.org"
@@ -167,7 +167,7 @@ _mv() {
mv $@
}
-sha512sums="cb1f0f5643c5244225255030bef974eb8d642c9a9f04d3a1ba44157b3848ca2ee0c1b96160c19e6e0e110d0065836f99936f00678690840aa8f34e22ecece874 rustc-1.22.1-src.tar.gz
+sha512sums="a1dbb1a625c6d8dfe9708e1cf478a49154b1eb0aba5ba67ac85518a8c7d1c70d2d86ac4d441156e9bfd0fd77ca241fb5491a2bd68aefcf0b3c2e164c3cc29e4e rustc-1.23.0-src.tar.gz
cee98ff6cded8a330e383b8b88423b10b7c2cdcb711b31f4685abae7a60f85869e87f3096eb2d90a83dafeeba98b6f153b5e67d88f5cacc368dc53c701fe495b musl-fix-static-linking.patch
360b0c1b6374cb356989b6f254da2dfc2ab2390c8251f0151492206b908ebf85c6ff57405394b3f46f1fc3e26f7c986bb9e924065f4c4dfa1d50fff2a99b5cd0 musl-fix-linux_musl_base.patch
dc6432293bd060d5e3a73f25870867654fae61995dcd919e244a2dc686b6107556deed8c59ca6002182bfeff5ebc1ca2b89c4028ab0fbfb79e65defe47c9b4b0 llvm-with-ffi.patch
@@ -176,6 +176,6 @@ b5c8a4faf3571b5c79b052103639ea3b14f094ec0999963602111608afa1159219f958decf0b45dd
d352614e7c774e181decae210140e789de7fc090327ff371981ad28a11ce51c8c01b27c1101a24bb84d75ed2f706f67868f7dbc52196d4ccdf4ebd2d6d6b6b5e minimize-rpath.patch
498f4649163974afc4f042c43cd0c15d36784031514201a2962061f288a9336c2bc9749f8d2308b8ce3656f8097b5fc5bef505f61e2a6ed422ef4153f5339d77 alpine-move-py-scripts-to-share.patch
0542e8ffeb7ff6017aeec84d99c14802c6536433b41dafe7c8fc0c40908548228f34ef142ad6ad94235115b05f02ce157553b470b0f242292f90f3125b249e94 alpine-change-rpath-to-rustlib.patch
-d769370adf0cb387d71aa85332fb77b9ebda0bca78599462a570dd23df0a9b6bcc18d815f4b0c012a3b90ad7f648b5d96f54a4dd88191db401cd681c391fa8a5 alpine-target.patch
+412bb856ce474c2a027d29be5dc9bbe6475ecf92fdf21c5b05f3aa234b86626652d582e7197681a52fff5e3c29b456137edb7b2dfa3a4346a6b3b487dfff7fa5 alpine-target.patch
7d59258d4462eba0207739a5c0c8baf1f19d9a396e5547bb4d59d700eb94d50ba6add2e523f3e94e29e993821018594625ea4ac86304fb58f7f8c82622a26ab0 install-template-shebang.patch
79549055dea81379c890b495c82456ab497a9179ec6702c59e11d0748bc668f47fc3d6a69c27a0545bb87c01318631dffc69260bf2d4badc75f53cbf7fad7528 check-rustc"
diff --git a/community/rust/alpine-target.patch b/community/rust/alpine-target.patch
index d8cd7d7b1c..4bb2173e5a 100644
--- a/community/rust/alpine-target.patch
+++ b/community/rust/alpine-target.patch
@@ -25,7 +25,7 @@ and distribution-specific quirks instead of polluting the main musl target of
/// Everything `rustc` knows about how to compile for a specific target.
--- /dev/null
+++ b/src/librustc_back/target/i586_alpine_linux_musl.rs
-@@ -0,0 +1,35 @@
+@@ -0,0 +1,36 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -43,6 +43,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ let mut base = super::linux_musl_base::opts();
+ base.cpu = "pentium4".to_string();
+ base.max_atomic_width = Some(64);
++ base.stack_probes = true;
+ base.crt_static_default = false;
+ base.static_position_independent_executables = true;
+ base.need_rpath = true;
@@ -63,7 +64,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+}
--- /dev/null
+++ b/src/librustc_back/target/x86_64_alpine_linux_musl.rs
-@@ -0,0 +1,35 @@
+@@ -0,0 +1,36 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -81,6 +82,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ let mut base = super::linux_musl_base::opts();
+ base.cpu = "x86-64".to_string();
+ base.max_atomic_width = Some(64);
++ base.stack_probes = true;
+ base.crt_static_default = false;
+ base.static_position_independent_executables = true;
+ base.need_rpath = true;