aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorMarat Safin <jeizsm@gmail.com>2018-07-01 14:31:20 +0300
committerJakub Jirutka <jakub@jirutka.cz>2018-07-02 21:55:35 +0200
commit958bd50f910e5d0d7120c3999c9347f036220962 (patch)
tree68f59dd6397cdd2bb084aad3110afa3a98f91a01 /community/rust
parentba505a5a6bbb08f43242e27787f6941acf777895 (diff)
downloadaports-958bd50f910e5d0d7120c3999c9347f036220962.tar.bz2
aports-958bd50f910e5d0d7120c3999c9347f036220962.tar.xz
community/rust: upgrade to 1.27.0
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD22
-rw-r--r--community/rust/alpine-target.patch32
-rw-r--r--community/rust/bootstrap-tool-respect-tool-config.patch12
-rw-r--r--community/rust/cargo-libressl27x.patch98
-rw-r--r--community/rust/cargo-tests-fix-build-target.patch27
-rw-r--r--community/rust/fix-configure-tools.patch35
-rw-r--r--community/rust/musl-fix-linux_musl_base.patch4
-rw-r--r--community/rust/need-rpath.patch4
-rw-r--r--community/rust/static-pie.patch12
9 files changed, 67 insertions, 179 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index dc1c5cbb66..ec591d4391 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -3,10 +3,10 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=rust
-pkgver=1.26.2
+pkgver=1.27.0
# TODO: bump to 6 as soon as we add llvm6
_llvmver=5
-_bootver=1.25.0
+_bootver=1.26.2
pkgrel=0
pkgdesc="The Rust Programming Language"
url="http://www.rust-lang.org"
@@ -68,12 +68,11 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
alpine-change-rpath-to-rustlib.patch
alpine-target.patch
install-template-shebang.patch
- fix-configure-tools.patch
bootstrap-tool-respect-tool-config.patch
ensure-stage0-libs-have-unique-metadata.patch
- cargo-libressl27x.patch
cargo-tests-fix-build-auth-http_auth_offered.patch
cargo-tests-ignore-resolving_minimum_version_with_transitive_deps.patch
+ cargo-tests-fix-build-target.patch
check-rustc
"
builddir="$srcdir/rustc-$pkgver-src"
@@ -273,21 +272,20 @@ _mv() {
mv $@
}
-sha512sums="e864d01890d8c9cf5c03f9e8572ee66c8619873f365190cc234ccf19883ea235215e42ab475d0921f82e1842f4e1a413aa43bb23cddb555bc24edb62b2dab9de rustc-1.26.2-src.tar.gz
+sha512sums="cd8fa2c748cbec7fab638cf5ea356fe55d64ec699c22dd493cd31d52f8d115a368942d2305c46e28dacff597de8748d327b1d2786502969f6dea93589295520d rustc-1.27.0-src.tar.gz
d26b0c87e2dce9f2aca561a47ed1ca987c4e1b272ab8b19c39433b63d4be03ca244ba97adc50e743fe50eb0b2f8109cd68a2f05e41d7411c58ef77ef253ca789 musl-fix-static-linking.patch
-ed209fa8e44764fce9e38f46006910d632b81708be5d84d281aa40cf4f78fb9f8ccb0dcac55cb4e5a5855a4e52fc322b72772006c5d5d1d4545cf2668e60f381 musl-fix-linux_musl_base.patch
+9ae8057e1f01b2f3a20906b9f82222b97aac0f1fce47471f724f1f2bd75f36f8be86cfc73ab6e6b09a9cfe5c1e5dc42780c3bac49e0cc453179c49580b3ebddc musl-fix-linux_musl_base.patch
e40d41a6dc5d400d6672f1836cd5b9e00391f7beb52e872d87db76bc95a606ce6aaae737a0256a1e5fba77c83bb223818d214dbe87028d47be65fb43c101595c llvm-with-ffi.patch
-a8ae797e487cb7722b2c88a641ae850d65997d296b1f9672d0ec23caff99846c6f2eaa27eb449fec31c51c3d490aee2900e722c3435fab95ed55a22fda583168 static-pie.patch
-7bf81f58935e56ab673ce85e0c81b94cfb78a5bfbb8c220683a4cf71d75dfdf3861300abf3867c46594d2db894d00e5c8f65983a2b9bfe8966582adfa7d149e3 need-rpath.patch
+c686b1fc63d415e10e6e27ade39c692cff534262f45978deb7e71e3f11e3a61c849008b63da3963c423e9dc29ee7eb0efb0400918855827e34987da74b443a23 static-pie.patch
+c139ded88ed6c90f39ea039e182c7f135832b460e0637a7a453e8247170dca4eee209351f16ebfb5dac466d4f2bf7d7f2568d7e1c9a3aa4190150453677b3510 need-rpath.patch
d352614e7c774e181decae210140e789de7fc090327ff371981ad28a11ce51c8c01b27c1101a24bb84d75ed2f706f67868f7dbc52196d4ccdf4ebd2d6d6b6b5e minimize-rpath.patch
0c0aa7eeddeb578c320a94696a4437fbf083ef4d6f8049512de82548285f37ec4460b5d04f087dc303a5f62a09b5d13b7f0c4fbbdb0b321147ae030e7282ac07 alpine-move-py-scripts-to-share.patch
61aa415d754e9e01236481a1f3c9d5242f2d633e6f11b998e9ffcc07bf5c182d87c0c973dab6f10e4bb3ab4b4a4857bf9ed8dd664c49a65f6175d27db2774db1 alpine-change-rpath-to-rustlib.patch
-b3be85bf54d03ba5a685c8e01246e047a169fedb1745182286fdb1ae8cb23e6723318276ef36ee0c54bf7e6d2bc86a46c479fb6c822b8b548d35fa094dde05d2 alpine-target.patch
+a688b4bc2420bf05c6ae724c9a4e6821267716032f69a9a44cb395407276df7fb37fc145f8d274b5fa03e7173c338871c9d2294a90726ef16bd087fbe6a77b66 alpine-target.patch
7d59258d4462eba0207739a5c0c8baf1f19d9a396e5547bb4d59d700eb94d50ba6add2e523f3e94e29e993821018594625ea4ac86304fb58f7f8c82622a26ab0 install-template-shebang.patch
-775a7a28a79d4150813caef6b5b1ee0771cf3cb5945eae427371618ff1fb097da9a0001e13f0f426e3a9636f75683bfe4bdff634456137e057f965ee2899b95a fix-configure-tools.patch
-b0f117423f0a9f51c2fecfcc63acabcd7da692946113b6e0aa30f2cff529a06bc41a2b075b410badab6c11fd4e1147b4af796e3e9a93608d3b43ee65b0a4aa02 bootstrap-tool-respect-tool-config.patch
+c2ccab15d48c11cc3af549a3944ca0d29cb3790345468f4f3779e5ac931554dea603e5523281fc391ba4a555ee468b516961c4cb8ecee007eadacf114f3d8758 bootstrap-tool-respect-tool-config.patch
df8caff62724e4d4ced52a72f919c3b41f272b5e547dac5aaccbc70f0cae2edf0002c755275e228944effac82fece63274e8fc717dca171b525fd51865151c75 ensure-stage0-libs-have-unique-metadata.patch
-a1c6cc6181d48e313c9c976cb403437cee8d49bda6ef612df7bc21981abc21177b6682ae6b1e4d4906d97ab21f32b310272f57b97ad68ad0f351cd923afeb2f2 cargo-libressl27x.patch
332a6af59edc507baa73eda1de60591dd4202f540541769ac1bcbc731267f4523ea309d2c3b1f5a9dc3db32831942a5d3d40b81882dad0bf0b5ee7f74f1d6477 cargo-tests-fix-build-auth-http_auth_offered.patch
3d6f027088e1ec189ce864bf5ed150ccad8be5d9fc0973f1b4d202eec6eab865834403335a9f0765bbfa54638aed7f5d5f2183ba9dfeab9f5bc4ef48111a8427 cargo-tests-ignore-resolving_minimum_version_with_transitive_deps.patch
+f7c09940a013f210c54e57770bbfbe7fa7a5670df6b8101c5058b0d94c1e297c2dbe358acf48ac3d4a36b15623643461d83b4b43c446144113318a4212623701 cargo-tests-fix-build-target.patch
c31fdfe8a9b3411576c75da46645cf0465b9053000a2ab49cf9b2f2733f679d6d33acbf236d67a20e14935d094a685453b7f1840180249f39d610fd0902c3125 check-rustc"
diff --git a/community/rust/alpine-target.patch b/community/rust/alpine-target.patch
index f5425a5e78..b9f22b02f2 100644
--- a/community/rust/alpine-target.patch
+++ b/community/rust/alpine-target.patch
@@ -7,8 +7,8 @@ This adds `$arch-alpine-linux-musl` targets to Rust to encode our toolchain
and distribution-specific quirks instead of polluting the main musl target of
`$arch-unknown-linux-musl`.
---- a/src/librustc_back/target/mod.rs
-+++ b/src/librustc_back/target/mod.rs
+--- a/src/librustc_target/spec/mod.rs
++++ b/src/librustc_target/spec/mod.rs
@@ -239,6 +239,11 @@
("armv7-unknown-cloudabi-eabihf", armv7_unknown_cloudabi_eabihf),
("i686-unknown-cloudabi", i686_unknown_cloudabi),
@@ -22,8 +22,8 @@ and distribution-specific quirks instead of polluting the main musl target of
/// Everything `rustc` knows about how to compile for a specific target.
--- /dev/null
-+++ b/src/librustc_back/target/i586_alpine_linux_musl.rs
-@@ -0,0 +1,36 @@
++++ b/src/librustc_target/spec/i586_alpine_linux_musl.rs
+@@ -0,0 +1,35 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -34,8 +34,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
-+use LinkerFlavor;
-+use target::{Target, TargetResult};
++use spec::{LinkerFlavor, Target, TargetResult};
+
+pub fn target() -> TargetResult {
+ let mut base = super::linux_musl_base::opts();
@@ -61,8 +60,8 @@ and distribution-specific quirks instead of polluting the main musl target of
+ })
+}
--- /dev/null
-+++ b/src/librustc_back/target/x86_64_alpine_linux_musl.rs
-@@ -0,0 +1,36 @@
++++ b/src/librustc_target/spec/x86_64_alpine_linux_musl.rs
+@@ -0,0 +1,35 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -73,8 +72,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
-+use LinkerFlavor;
-+use target::{Target, TargetResult};
++use spec::{LinkerFlavor, Target, TargetResult};
+
+pub fn target() -> TargetResult {
+ let mut base = super::linux_musl_base::opts();
@@ -100,8 +98,8 @@ and distribution-specific quirks instead of polluting the main musl target of
+ })
+}
--- /dev/null
-+++ b/src/librustc_back/target/aarch64_alpine_linux_musl.rs
-@@ -0,0 +1,39 @@
++++ b/src/librustc_target/spec/aarch64_alpine_linux_musl.rs
+@@ -0,0 +1,38 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -112,8 +110,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
-+use LinkerFlavor;
-+use target::{Target, TargetOptions, TargetResult};
++use spec::{LinkerFlavor, Target, TargetOptions, TargetResult};
+
+pub fn target() -> TargetResult {
+ let mut base = super::linux_musl_base::opts();
@@ -142,8 +139,8 @@ and distribution-specific quirks instead of polluting the main musl target of
+ })
+}
--- /dev/null
-+++ b/src/librustc_back/target/arm_alpine_linux_musleabihf.rs
-@@ -0,0 +1,41 @@
++++ b/src/librustc_target/spec/arm_alpine_linux_musleabihf.rs
+@@ -0,0 +1,40 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -154,8 +151,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
-+use LinkerFlavor;
-+use target::{Target, TargetOptions, TargetResult};
++use spec::{LinkerFlavor, Target, TargetOptions, TargetResult};
+
+pub fn target() -> TargetResult {
+ let mut base = super::linux_musl_base::opts();
diff --git a/community/rust/bootstrap-tool-respect-tool-config.patch b/community/rust/bootstrap-tool-respect-tool-config.patch
index 2ff038ed69..958ef29e5c 100644
--- a/community/rust/bootstrap-tool-respect-tool-config.patch
+++ b/community/rust/bootstrap-tool-respect-tool-config.patch
@@ -8,9 +8,9 @@ Subject: [PATCH] Fix tool builder to respect build.tools config
fn should_run(run: ShouldRun) -> ShouldRun {
let builder = run.builder;
-- run.path("src/tools/cargo").default_condition(builder.build.config.extended)
-+ run.path("src/tools/cargo").default_condition(builder.build.config.extended
-+ && builder.build.config.tools.as_ref().map_or(true, |t| t.contains("cargo")))
+- run.path("src/tools/cargo").default_condition(builder.config.extended)
++ run.path("src/tools/cargo").default_condition(builder.config.extended
++ && builder.config.tools.as_ref().map_or(true, |t| t.contains("cargo")))
}
fn make_run(run: RunConfig) {
@@ -18,9 +18,9 @@ Subject: [PATCH] Fix tool builder to respect build.tools config
fn should_run(run: ShouldRun) -> ShouldRun {
let builder = run.builder;
-- run.path($path).default_condition(builder.build.config.extended)
-+ run.path($path).default_condition(builder.build.config.extended
-+ && builder.build.config.tools.as_ref().map_or(true, |t| t.contains($tool_name)))
+- run.path($path).default_condition(builder.config.extended)
++ run.path($path).default_condition(builder.config.extended
++ && builder.config.tools.as_ref().map_or(true, |t| t.contains($tool_name)))
}
fn make_run(run: RunConfig) {
diff --git a/community/rust/cargo-libressl27x.patch b/community/rust/cargo-libressl27x.patch
deleted file mode 100644
index e1309f8c4a..0000000000
--- a/community/rust/cargo-libressl27x.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-Add support for LibreSSL 2.7.x. This patch was assembled from the following
-commits in rust-openssl's repository:
-
-* f0614f4acd6d24fbb100b8365bc54662d4f62df2
-* 23ca9d2832ff54bc2067f99473802a3fbead0f3f
-* 03c6bcc159c5b987779da4f01c6f76bd77a13ce3
-* 01855a4f6470db6d71bccece1db33bc4b89b4c9b
-
---- a/src/vendor/openssl-sys/build.rs
-+++ b/src/vendor/openssl-sys/build.rs
-@@ -323,8 +323,10 @@ fn validate_headers(include_dirs: &[PathBuf]) -> Version {
- #include <openssl/opensslv.h>
- #include <openssl/opensslconf.h>
-
--#if LIBRESSL_VERSION_NUMBER >= 0x20700000
-+#if LIBRESSL_VERSION_NUMBER >= 0x20800000
- RUST_LIBRESSL_NEW
-+#elif LIBRESSL_VERSION_NUMBER >= 0x20700000
-+RUST_LIBRESSL_27X
- #elif LIBRESSL_VERSION_NUMBER >= 0x20603000
- RUST_LIBRESSL_26X
- #elif LIBRESSL_VERSION_NUMBER >= 0x20602000
-@@ -473,6 +475,13 @@ See rust-openssl README for more information:
- println!("cargo:libressl_version=26x");
- println!("cargo:version=101");
- Version::Libressl
-+ } else if expanded.contains("RUST_LIBRESSL_27X") {
-+ println!("cargo:rustc-cfg=libressl");
-+ println!("cargo:rustc-cfg=libressl27");
-+ println!("cargo:libressl=true");
-+ println!("cargo:libressl_version=27x");
-+ println!("cargo:version=101");
-+ Version::Libressl
- } else if expanded.contains("RUST_OPENSSL_111") {
- println!("cargo:rustc-cfg=ossl111");
- println!("cargo:rustc-cfg=ossl110");
-@@ -501,7 +510,7 @@ See rust-openssl README for more information:
- "
-
- This crate is only compatible with OpenSSL 1.0.1 through 1.1.1, or LibreSSL 2.5
--and 2.6, but a different version of OpenSSL was found. The build is now aborting
-+through 2.7, but a different version of OpenSSL was found. The build is now aborting
- due to this version mismatch.
-
- "
---- a/src/vendor/openssl-sys/src/lib.rs
-+++ b/src/vendor/openssl-sys/src/lib.rs
-@@ -1249,14 +1249,14 @@ pub const SSL_VERIFY_NONE: c_int = 0;
- pub const SSL_VERIFY_PEER: c_int = 1;
- pub const SSL_VERIFY_FAIL_IF_NO_PEER_CERT: c_int = 2;
-
--#[cfg(not(any(libressl261, libressl262, libressl26x, ossl101)))]
-+#[cfg(not(any(libressl261, libressl262, libressl26x, libressl27, ossl101)))]
- pub const SSL_OP_TLSEXT_PADDING: c_ulong = 0x00000010;
--#[cfg(any(libressl261, libressl262, libressl26x))]
-+#[cfg(any(libressl261, libressl262, libressl26x, libressl27))]
- pub const SSL_OP_TLSEXT_PADDING: c_ulong = 0x0;
- pub const SSL_OP_DONT_INSERT_EMPTY_FRAGMENTS: c_ulong = 0x00000800;
--#[cfg(not(any(libressl261, libressl262, libressl26x)))]
-+#[cfg(not(any(libressl261, libressl262, libressl26x, libressl27)))]
- pub const SSL_OP_CRYPTOPRO_TLSEXT_BUG: c_ulong = 0x80000000;
--#[cfg(any(libressl261, libressl262, libressl26x))]
-+#[cfg(any(libressl261, libressl262, libressl26x, libressl27))]
- pub const SSL_OP_CRYPTOPRO_TLSEXT_BUG: c_ulong = 0x0;
- pub const SSL_OP_LEGACY_SERVER_CONNECT: c_ulong = 0x00000004;
- #[cfg(not(libressl))]
---- a/src/vendor/openssl-sys/src/libressl/mod.rs
-+++ b/src/vendor/openssl-sys/src/libressl/mod.rs
-@@ -331,9 +331,9 @@ pub const SSL_CTRL_OPTIONS: c_int = 32;
- pub const SSL_CTRL_CLEAR_OPTIONS: c_int = 77;
- pub const SSL_CTRL_SET_ECDH_AUTO: c_int = 94;
-
--#[cfg(any(libressl261, libressl262, libressl26x))]
-+#[cfg(any(libressl261, libressl262, libressl26x, libressl27))]
- pub const SSL_OP_ALL: c_ulong = 0x4;
--#[cfg(not(any(libressl261, libressl262, libressl26x)))]
-+#[cfg(not(any(libressl261, libressl262, libressl26x, libressl27)))]
- pub const SSL_OP_ALL: c_ulong = 0x80000014;
- pub const SSL_OP_CISCO_ANYCONNECT: c_ulong = 0x0;
- pub const SSL_OP_NO_COMPRESSION: c_ulong = 0x0;
-@@ -346,9 +346,9 @@ pub const SSL_OP_MICROSOFT_BIG_SSLV3_BUFFER: c_ulong = 0x0;
- pub const SSL_OP_SSLEAY_080_CLIENT_DH_BUG: c_ulong = 0x0;
- pub const SSL_OP_TLS_D5_BUG: c_ulong = 0x0;
- pub const SSL_OP_TLS_BLOCK_PADDING_BUG: c_ulong = 0x0;
--#[cfg(any(libressl261, libressl262, libressl26x))]
-+#[cfg(any(libressl261, libressl262, libressl26x, libressl27))]
- pub const SSL_OP_SINGLE_ECDH_USE: c_ulong = 0x0;
--#[cfg(not(any(libressl261, libressl262, libressl26x)))]
-+#[cfg(not(any(libressl261, libressl262, libressl26x, libressl27)))]
- pub const SSL_OP_SINGLE_ECDH_USE: c_ulong = 0x00080000;
- pub const SSL_OP_SINGLE_DH_USE: c_ulong = 0x00100000;
- pub const SSL_OP_NO_SSLv2: c_ulong = 0x0;
---- a/src/vendor/openssl-sys/.cargo-checksum.json
-+++ b/src/vendor/openssl-sys/.cargo-checksum.json
-@@ -1 +1 @@
--{"files":{".cargo-ok":"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855","Cargo.toml":"84ca02d51869a94d631415447762ab0c12592d9a18934cdbdbe8974fdf77ffd5","Cargo.toml.orig":"0c05fcc731ca9be285c38a16086339cca2b7a57642ea969e43a1813fb032ae78","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"d95a3aa19289431dd60885a27f8b57860fd5906cf001780e14e93b18c9136a47","build.rs":"59dbe79ac18a2cd1aa01d4847d8dc8f3dcb2496dfd2a467308167498d58d2cf3","src/lib.rs":"9c53b3ba767f0924513009e52715bcc2b6b3bc9ded878dfe54fa16d080aff48c","src/libressl/mod.rs":"192fbed74cedac430dda84449409f9cd93f20da01db669912bcddfe4d5d1a51e","src/libressl/v250.rs":"8e64255d67e9e684b6d76184f96cfb8dca34c7f241fdbc08a982a221644257ea","src/libressl/v25x.rs":"08a71c8fac38851f9b9e58ae5f1ca39185a8057f93accc142da822c6bf3488f4","src/ossl10x.rs":"5df1084914e88eb9d73d57a4b78a2ea7fde9aeb58c5322a5a99b3ab19720cb8d","src/ossl110.rs":"54bda26bdf5488da9a904854b7171a4005e99d930605ed8279644104f16b3a85","src/ossl111.rs":"cb65c7ef481e50e1901c0b1f533703e4609858c8642b4569a66f037f23d515ee"},"package":"d6fdc5c4a02e69ce65046f1763a0181107038e02176233acb0b3351d7cc588f9"}
-\ No newline at end of file
-+{"files":{".cargo-ok":"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855","Cargo.toml":"84ca02d51869a94d631415447762ab0c12592d9a18934cdbdbe8974fdf77ffd5","Cargo.toml.orig":"0c05fcc731ca9be285c38a16086339cca2b7a57642ea969e43a1813fb032ae78","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"d95a3aa19289431dd60885a27f8b57860fd5906cf001780e14e93b18c9136a47","build.rs":"0f3e7e9a56d842afb30e5aecaaac3a2b82ccc48be785dcf1514380bc03a2bf24","src/lib.rs":"99135b825f8481f7f7f1861fd8447daad79add9576bd449ad52636014c5e4c0c","src/libressl/mod.rs":"803488d553de18dfefb6d5e8def39630ec45144ee1a8dd936a4e0e5e7fe50c38","src/libressl/v250.rs":"8e64255d67e9e684b6d76184f96cfb8dca34c7f241fdbc08a982a221644257ea","src/libressl/v25x.rs":"08a71c8fac38851f9b9e58ae5f1ca39185a8057f93accc142da822c6bf3488f4","src/ossl10x.rs":"5df1084914e88eb9d73d57a4b78a2ea7fde9aeb58c5322a5a99b3ab19720cb8d","src/ossl110.rs":"54bda26bdf5488da9a904854b7171a4005e99d930605ed8279644104f16b3a85","src/ossl111.rs":"cb65c7ef481e50e1901c0b1f533703e4609858c8642b4569a66f037f23d515ee"},"package":"d6fdc5c4a02e69ce65046f1763a0181107038e02176233acb0b3351d7cc588f9"}
diff --git a/community/rust/cargo-tests-fix-build-target.patch b/community/rust/cargo-tests-fix-build-target.patch
new file mode 100644
index 0000000000..98195f697c
--- /dev/null
+++ b/community/rust/cargo-tests-fix-build-target.patch
@@ -0,0 +1,27 @@
+failures:
+
+---- cfg::cfg_looks_at_rustflags_for_target stdout ----
+ running `/home/build/aports/community/rust/src/rustc-1.27.0-src/build/x86_64-alpine-linux-musl/stage2-tools/x86_64-alpine-linux-musl/release/cargo build --target x86_64-unkn
+own-linux-gnu`
+thread 'cfg::cfg_looks_at_rustflags_for_target' panicked at '
+Expected: execs
+ but: exited with exit code: 101
+--- stdout
+
+--- stderr
+ Compiling b v0.0.1 (file:///home/build/aports/community/rust/src/rustc-1.27.0-src/build/x86_64-alpine-linux-musl/stage2-tools/x86_64-alpine-linux-musl/cit/t356/foo/b)
+error[E0463]: can't find crate for `std`
+ |
+ = note: the `x86_64-unknown-linux-gnu` target may not be installed
+
+--- a/src/tools/cargo/tests/testsuite/cfg.rs
++++ b/src/tools/cargo/tests/testsuite/cfg.rs
+@@ -449,7 +449,7 @@ fn cfg_looks_at_rustflags_for_target() {
+ .build();
+
+ assert_that(
+- p.cargo("build --target x86_64-unknown-linux-gnu")
++ p.cargo("build --target x86_64-alpine-linux-musl")
+ .env("RUSTFLAGS", "--cfg with_b"),
+ execs().with_status(0),
+ );
diff --git a/community/rust/fix-configure-tools.patch b/community/rust/fix-configure-tools.patch
deleted file mode 100644
index 226ce76a65..0000000000
--- a/community/rust/fix-configure-tools.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 51b17db7707d745af25558eaa32aaf10080a9a03 Mon Sep 17 00:00:00 2001
-From: Dan Callaghan <djc@djc.id.au>
-Date: Sun, 8 Apr 2018 14:59:15 +1000
-Subject: [PATCH] configure.py --tools should set a list instead of a string
-
-Currently the --tools option does not work because it is setting a string value
-for 'build.tools'. It should be a list of strings instead.
-
-Patch-Source: https://github.com/rust-lang/rust/commit/51b17db7707d745af25558eaa32aaf10080a9a03
----
- src/bootstrap/configure.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/bootstrap/configure.py b/src/bootstrap/configure.py
-index a5c373d5d5e7..b06968d313ba 100755
---- a/src/bootstrap/configure.py
-+++ b/src/bootstrap/configure.py
-@@ -145,7 +145,7 @@ def v(*args):
- o("full-bootstrap", "build.full-bootstrap", "build three compilers instead of two")
- o("extended", "build.extended", "build an extended rust tool set")
-
--v("tools", "build.tools", "List of extended tools will be installed")
-+v("tools", None, "List of extended tools will be installed")
- v("build", "build.build", "GNUs ./configure syntax LLVM build triple")
- v("host", None, "GNUs ./configure syntax LLVM host triples")
- v("target", None, "GNUs ./configure syntax LLVM target triples")
-@@ -321,6 +321,8 @@ def set(key, value):
- set('target.{}.llvm-config'.format(build()), value + '/bin/llvm-config')
- elif option.name == 'jemalloc-root':
- set('target.{}.jemalloc'.format(build()), value + '/libjemalloc_pic.a')
-+ elif option.name == 'tools':
-+ set('build.tools', value.split(','))
- elif option.name == 'host':
- set('build.host', value.split(','))
- elif option.name == 'target':
diff --git a/community/rust/musl-fix-linux_musl_base.patch b/community/rust/musl-fix-linux_musl_base.patch
index df7da501e0..4ddcac9d40 100644
--- a/community/rust/musl-fix-linux_musl_base.patch
+++ b/community/rust/musl-fix-linux_musl_base.patch
@@ -4,8 +4,8 @@ Subject: [PATCH] Fix linux_musl_base for native musl host
See https://github.com/rust-lang/rust/pull/40113
---- a/src/librustc_back/target/linux_musl_base.rs
-+++ b/src/librustc_back/target/linux_musl_base.rs
+--- a/src/librustc_target/spec/linux_musl_base.rs
++++ b/src/librustc_target/spec/linux_musl_base.rs
@@ -14,54 +14,14 @@
pub fn opts() -> TargetOptions {
let mut base = super::linux_base::opts();
diff --git a/community/rust/need-rpath.patch b/community/rust/need-rpath.patch
index d7689610b9..b875df5b91 100644
--- a/community/rust/need-rpath.patch
+++ b/community/rust/need-rpath.patch
@@ -11,8 +11,8 @@ RPATH additions, but unfortunately there's no clean way to detect this.
As such, we have to resort to checking the `RUSTC_BOOTSTRAP` variable.
Hacky hacky!
---- a/src/librustc_back/target/mod.rs
-+++ b/src/librustc_back/target/mod.rs
+--- a/src/librustc_target/spec/mod.rs
++++ b/src/librustc_target/spec/mod.rs
@@ -379,6 +379,8 @@
pub allows_weak_linkage: bool,
/// Whether the linker support rpaths or not. Defaults to false.
diff --git a/community/rust/static-pie.patch b/community/rust/static-pie.patch
index 542dbffb88..c6ffdbe00c 100644
--- a/community/rust/static-pie.patch
+++ b/community/rust/static-pie.patch
@@ -40,8 +40,8 @@ library, just like static binaries, but more secure.
0x000000006ffffff9 (RELACOUNT) 223
0x0000000000000000 (NULL) 0x0
---- a/src/librustc_back/target/linux_musl_base.rs
-+++ b/src/librustc_back/target/linux_musl_base.rs
+--- a/src/librustc_target/spec/linux_musl_base.rs
++++ b/src/librustc_target/spec/linux_musl_base.rs
@@ -25,5 +25,8 @@
// These targets allow the user to choose between static and dynamic linking.
base.crt_static_respected = true;
@@ -51,8 +51,8 @@ library, just like static binaries, but more secure.
+
base
}
---- a/src/librustc_back/target/mod.rs
-+++ b/src/librustc_back/target/mod.rs
+--- a/src/librustc_target/spec/mod.rs
++++ b/src/librustc_target/spec/mod.rs
@@ -388,6 +388,8 @@
/// the functions in the executable are not randomized and can be used
/// during an exploit of a vulnerability in any code.
@@ -89,8 +89,8 @@ library, just like static binaries, but more secure.
position_independent_executable = true;
}
}
---- a/src/librustc_back/target/mod.rs
-+++ b/src/librustc_back/target/mod.rs
+--- a/src/librustc_target/spec/mod.rs
++++ b/src/librustc_target/spec/mod.rs
@@ -778,7 +778,8 @@
key!(has_rpath, bool);
key!(no_default_libraries, bool);