aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-20 18:19:39 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-20 20:16:43 +0200
commitb8367044e174d43c4ea1ce4b423e050679d728cd (patch)
tree0f89465787586c5bc9e8cf7156a5afcdd791c314 /community/rust
parent5dff30424f8599a2c56489a14a7d79e4ea38eabc (diff)
downloadaports-b8367044e174d43c4ea1ce4b423e050679d728cd.tar.bz2
aports-b8367044e174d43c4ea1ce4b423e050679d728cd.tar.xz
community/rust: build with analysis data and add subpkg -analysis
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index b6883a8ef2..f275f06437 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -7,7 +7,7 @@ pkgver=1.26.0
# TODO: bump to 6 as soon as we add llvm6
_llvmver=5
_bootver=1.25.0
-pkgrel=0
+pkgrel=1
pkgdesc="The Rust Programming Language"
url="http://www.rust-lang.org"
arch="x86_64"
@@ -47,6 +47,7 @@ options="!archcheck"
subpackages="
$pkgname-dbg
$pkgname-stdlib
+ $pkgname-analysis
$pkgname-gdb::noarch
$pkgname-lldb::noarch
$pkgname-doc
@@ -113,7 +114,7 @@ build() {
--musl-root="/usr" \
--disable-docs \
--enable-extended \
- --tools="cargo" \
+ --tools="analysis,cargo" \
--enable-llvm-link-shared \
--enable-option-checking \
--enable-locked-deps \
@@ -182,6 +183,13 @@ stdlib() {
_mv "$pkgdir"/$_rlibdir/*.rlib "$subpkgdir"/$_rlibdir/
}
+analysis() {
+ pkgdesc="Compiler analysis data for the Rust standard library"
+ depends="$pkgname-stdlib=$pkgver-r$pkgrel"
+
+ _mv "$pkgdir"/$_rlibdir/../analysis "$subpkgdir"/${_rlibdir%/*}/
+}
+
gdb() {
pkgdesc="GDB pretty printers for Rust"
depends="$pkgname gdb"