aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-21 15:03:35 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-21 14:55:24 +0200
commitf64f617640a377343a8836f60e08f627e48b4a78 (patch)
treefd3e396d50a78417e2b25c3f56a7939727b6d091 /community/rust
parente13872761f998baf7d00d9d5d69e1f05d3d68b83 (diff)
downloadaports-f64f617640a377343a8836f60e08f627e48b4a78.tar.bz2
aports-f64f617640a377343a8836f60e08f627e48b4a78.tar.xz
community/rust: upgrade to 1.27.2
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index ec591d4391..a85a70e2c9 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -3,10 +3,10 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=rust
-pkgver=1.27.0
+pkgver=1.27.2
# TODO: bump to 6 as soon as we add llvm6
_llvmver=5
-_bootver=1.26.2
+_bootver=1.27.0
pkgrel=0
pkgdesc="The Rust Programming Language"
url="http://www.rust-lang.org"
@@ -102,6 +102,8 @@ build() {
# jemalloc is disabled, because it increases size of statically linked
# binaries produced by rustc (stripped hello_world 186 kiB vs. 358 kiB)
# for only tiny performance boost (even negative in some tests).
+ # TODO: Remove --set="rust.deny-warnings=false" with upgrade to 1.28.0,
+ # it's workaround for https://github.com/rust-lang/rust/issues/51650.
./configure \
--build="$CBUILD" \
--host="$CTARGET" \
@@ -119,7 +121,8 @@ build() {
--enable-option-checking \
--enable-locked-deps \
--enable-vendor \
- --disable-jemalloc
+ --disable-jemalloc \
+ --set="rust.deny-warnings=false"
./x.py build -v --jobs ${JOBS:-2}
}
@@ -272,7 +275,7 @@ _mv() {
mv $@
}
-sha512sums="cd8fa2c748cbec7fab638cf5ea356fe55d64ec699c22dd493cd31d52f8d115a368942d2305c46e28dacff597de8748d327b1d2786502969f6dea93589295520d rustc-1.27.0-src.tar.gz
+sha512sums="a4dacae9b1652fa03d5262ccd4d503953743d3b088de0125ea7761d4d0b045e19a8a6ca3fef1d7c7fbbb33ec2516c7ea4c93130475a6af34dc01dce16587b3f9 rustc-1.27.2-src.tar.gz
d26b0c87e2dce9f2aca561a47ed1ca987c4e1b272ab8b19c39433b63d4be03ca244ba97adc50e743fe50eb0b2f8109cd68a2f05e41d7411c58ef77ef253ca789 musl-fix-static-linking.patch
9ae8057e1f01b2f3a20906b9f82222b97aac0f1fce47471f724f1f2bd75f36f8be86cfc73ab6e6b09a9cfe5c1e5dc42780c3bac49e0cc453179c49580b3ebddc musl-fix-linux_musl_base.patch
e40d41a6dc5d400d6672f1836cd5b9e00391f7beb52e872d87db76bc95a606ce6aaae737a0256a1e5fba77c83bb223818d214dbe87028d47be65fb43c101595c llvm-with-ffi.patch