aboutsummaryrefslogtreecommitdiffstats
path: root/community/spice-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:30:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:05 +0000
commit409d46bdce6e4179aa3802f70685c9f1b3927f33 (patch)
tree462c4a6f61bd52c2a2b54e477d89ef04dccf361c /community/spice-gtk
parent82de30fe3c7a65cdb89c05b5e75850d178bef09a (diff)
downloadaports-409d46bdce6e4179aa3802f70685c9f1b3927f33.tar.bz2
aports-409d46bdce6e4179aa3802f70685c9f1b3927f33.tar.xz
community/spice-gtk: upgrade to 0.35
Diffstat (limited to 'community/spice-gtk')
-rw-r--r--community/spice-gtk/APKBUILD23
-rw-r--r--community/spice-gtk/libressl.patch39
2 files changed, 55 insertions, 7 deletions
diff --git a/community/spice-gtk/APKBUILD b/community/spice-gtk/APKBUILD
index f07b327486..f3d35ab6ec 100644
--- a/community/spice-gtk/APKBUILD
+++ b/community/spice-gtk/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
-pkgver=0.34
-pkgrel=3
+pkgver=0.35
+pkgrel=0
pkgdesc="A GTK+ widget for SPICE clients"
url="http://spice-space.org/page/Spice-Gtk"
arch="all"
license="LGPL-2.0-or-later"
depends=""
-depends_dev="gtk+3.0-dev celt051-dev polkit-dev libxrandr-dev libressl-dev
+depends_dev="gtk+3.0-dev polkit-dev libxrandr-dev libressl-dev
cyrus-sasl-dev gst-plugins-base-dev libjpeg-turbo-dev zlib-dev
- acl-dev lz4-dev"
+ acl-dev lz4-dev opus-dev"
makedepends="$depends_dev bash usbutils python2-dev eudev-dev phodav-dev
usbredir-dev libusb-dev libsoup-dev spice-protocol
polkit-dev py-parsing gobject-introspection-dev
@@ -19,6 +19,7 @@ options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib"
source="http://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2
+ libressl.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -32,6 +33,11 @@ build() {
--mandir=/usr/share/man \
--with-gtk=3.0 \
--with-audio=gstreamer \
+ --disable-celt051 \
+ --disable-werror \
+ --enable-webdav \
+ --enable-lz4 \
+ --enable-opus \
--enable-smartcard=no \
--enable-usbredir=yes
make
@@ -50,10 +56,13 @@ tools() {
glib() {
pkgdesc=""
- mkdir -p "$subpkgdir"/usr/lib
+ mkdir -p "$subpkgdir"/usr/lib \
+ "$subpkgdir"/usr/lib/girepository-1.0/
mv "$pkgdir"/usr/lib/*-glib-*.so* \
- "$pkgdir"/usr/lib/*controller.so.* \
"$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/girepository-1.0/SpiceClientGLib-*.typelib \
+ "$subpkgdir"/usr/lib/girepository-1.0/
}
-sha512sums="17ea737511855b47f5eaf5143756483542cf8ee83f8d276cbfb2c0407355f68ed329fcbed8a67737179f3e53587710634d6faa856590234ee68be7b4b13f2689 spice-gtk-0.34.tar.bz2"
+sha512sums="f0914a4a9baf892e39dab7d51aa9f5ab4dbb4ef01f09da158b20756f890745837d0a6c8c1f7897844e695be2ed01f3b1d04ada1cacc958b5cfadb0d4bf7c4729 spice-gtk-0.35.tar.bz2
+f5e029e59bb64f073aea2fb2416e54d460981b365807f161795810a56a6268d4da681e3d64d17c2e8ed5bc49f736bbc88b933bedbf790b19ca91e599a8829f7e libressl.patch"
diff --git a/community/spice-gtk/libressl.patch b/community/spice-gtk/libressl.patch
new file mode 100644
index 0000000000..4c362b0ae1
--- /dev/null
+++ b/community/spice-gtk/libressl.patch
@@ -0,0 +1,39 @@
+diff --git a/spice-common/common/ssl_verify.c b/spice-common/common/ssl_verify.c
+index 27aa5d3..a9ed650 100644
+--- a/spice-common/common/ssl_verify.c
++++ b/spice-common/common/ssl_verify.c
+@@ -33,7 +33,7 @@
+ #include <string.h>
+ #include <gio/gio.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined (LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000
+ static const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1)
+ {
+ return M_ASN1_STRING_data(asn1);
+diff --git a/src/bio-gio.c b/src/bio-gio.c
+index 30aa73b..6b1ef9a 100644
+--- a/src/bio-gio.c
++++ b/src/bio-gio.c
+@@ -23,7 +23,7 @@
+ #include "spice-util.h"
+ #include "bio-gio.h"
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000
+ static BIO_METHOD one_static_bio;
+
+ static int BIO_meth_set_read(BIO_METHOD *biom,
+diff --git a/src/spice-channel.c b/src/spice-channel.c
+index 6f3ca27..55344a3 100644
+--- a/src/spice-channel.c
++++ b/src/spice-channel.c
+@@ -55,7 +55,7 @@ static void spice_channel_reset_capabilities(SpiceChannel *channel);
+ static void spice_channel_send_migration_handshake(SpiceChannel *channel);
+ static gboolean channel_connect(SpiceChannel *channel, gboolean tls);
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000
+ static RSA *EVP_PKEY_get0_RSA(EVP_PKEY *pkey)
+ {
+ if (pkey->type != EVP_PKEY_RSA) {