aboutsummaryrefslogtreecommitdiffstats
path: root/community/spice-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-16 19:23:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:05 +0000
commitfe034db785118a94292405e7336c537640f393d6 (patch)
tree056ebd6961de28b2ffe787db5c6a63bffecd0ada /community/spice-gtk
parent202f4bea916b0cf974b38ced96ab8fca0b192e3f (diff)
downloadaports-fe034db785118a94292405e7336c537640f393d6.tar.bz2
aports-fe034db785118a94292405e7336c537640f393d6.tar.xz
main/spice-gtk: move from main
Diffstat (limited to 'community/spice-gtk')
-rw-r--r--community/spice-gtk/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/community/spice-gtk/APKBUILD b/community/spice-gtk/APKBUILD
new file mode 100644
index 0000000000..f07b327486
--- /dev/null
+++ b/community/spice-gtk/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice-gtk
+pkgver=0.34
+pkgrel=3
+pkgdesc="A GTK+ widget for SPICE clients"
+url="http://spice-space.org/page/Spice-Gtk"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=""
+depends_dev="gtk+3.0-dev celt051-dev polkit-dev libxrandr-dev libressl-dev
+ cyrus-sasl-dev gst-plugins-base-dev libjpeg-turbo-dev zlib-dev
+ acl-dev lz4-dev"
+makedepends="$depends_dev bash usbutils python2-dev eudev-dev phodav-dev
+ usbredir-dev libusb-dev libsoup-dev spice-protocol
+ polkit-dev py-parsing gobject-introspection-dev
+ "
+options="suid"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
+ spice-glib:glib"
+source="http://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --with-gtk=3.0 \
+ --with-audio=gstreamer \
+ --enable-smartcard=no \
+ --enable-usbredir=yes
+ make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+tools() {
+ pkgdesc=""
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+glib() {
+ pkgdesc=""
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*-glib-*.so* \
+ "$pkgdir"/usr/lib/*controller.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+sha512sums="17ea737511855b47f5eaf5143756483542cf8ee83f8d276cbfb2c0407355f68ed329fcbed8a67737179f3e53587710634d6faa856590234ee68be7b4b13f2689 spice-gtk-0.34.tar.bz2"