aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxiv
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 12:18:56 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 12:19:49 +0000
commit3039b7460d922d8998cfd56520441e099ef170df (patch)
tree8d1b025692bc57cb5694858ebd7ef1391464e264 /community/sxiv
parentfd5ff3b7492913f7d9392a8c3c3345c3232c1590 (diff)
downloadaports-3039b7460d922d8998cfd56520441e099ef170df.tar.bz2
aports-3039b7460d922d8998cfd56520441e099ef170df.tar.xz
community/sxiv: add check function
As upstream doesn't provide a suite test, run -help to test if the binary actually works.
Diffstat (limited to 'community/sxiv')
-rw-r--r--community/sxiv/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/sxiv/APKBUILD b/community/sxiv/APKBUILD
index 53c3c711ef..1d1756a735 100644
--- a/community/sxiv/APKBUILD
+++ b/community/sxiv/APKBUILD
@@ -2,16 +2,12 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=sxiv
pkgver=24
-pkgrel=0
+pkgrel=1
pkgdesc="Simple X Image Viewer"
url="https://github.com/muennich/sxiv"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
makedepends="imlib2-dev giflib-dev libexif-dev libxft-dev"
-install=""
-options="!check" # upstream doesn't have a test suite
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -20,6 +16,11 @@ build() {
make -C "$builddir"
}
+check() {
+ cd "$builddir"
+ ./sxiv -help > /dev/null
+}
+
package() {
make PREFIX=/usr DESTDIR="$pkgdir" \
-C "$builddir" install